ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Niels Beekman" <n.beek...@wis.nl>
Subject RE: Caching problems
Date Mon, 02 Apr 2007 15:56:05 GMT
Did you enable caching globally in the config file?

Niels

-----Original Message-----
From: Brendan.McKenna@mdsuk.com [mailto:Brendan.McKenna@mdsuk.com] 
Sent: maandag 2 april 2007 17:54
To: user-java@ibatis.apache.org
Subject: Caching problems

Hi all,

        I'm having a bit of a problem with caching.  I have (I believe) 
set it up properly in my SqlMap file (see below).  I have a program that

executes the 'getAllFull' query twice, however, and both times I am
seeing 
the query being executed in the output log messages (see a little
further 
below).

        Any help in getting this caching working would be greatly 
appreciated.

        A couple of additional points.  All of my attempts have been
done 
using iBATIS 2.3.0.677.  I initially tried using Spring DAOs (using
Spring 
2.0.3), and saw the same thing.  In order to eliminate the possibility 
that the problem originated in the Spring/iBATIS interface, I then 
re-implemented my DAO using iBATIS DAOs (2.2.0-638), however I am still 
seeing the same thing.  I am using the JDBC transaction manager and
Oracle 
10.0.2 for my database.  The table I'm using is the EMP table in
Oracle's 
scott/tiger demo data (well, and the DEPT table, to get the department 
name).  FYI, I've tried both with and without explicit transactions, and

have seen no difference.  I'm fairly certain that I'm doing something 
wrong, I just don't know what.....

        Thanks in advance,

                Brendan


Mime
View raw message