ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Butler" <jeffgbut...@gmail.com>
Subject Re: Abator RAD 6 bug ? : problem with generatorSet attribute
Date Sat, 17 Mar 2007 01:40:24 GMT
The workaround is to upgrade to RAD 7.  RAD 6 does not support version
1.0of Abator because it is only eclipse
3.0.  So only features of Abator that were in version 0.6.5 are supported
(generatorSet is not one of this features).

When forced to use RAD 6, I prefer to run Abator with the Ant support in
RAD - it means I have to merge the Java files by hand, but this is usually
pretty easy to do.

Jeff Butler


On 3/16/07, Koen De Jaeger <kdejaeger@gmail.com> wrote:
>
> Hello people,
>
> I wanted to use the eclipse plugin because it merges the generated files
> automatically.
> The problem I have is that running abator in this way does not accept the
> generatorSet attribute. (it works in eclipse but not in RAD)
>
> If I specify it like this : <abatorContext generatorSet="Java2">
>
> I get the error :
>
> XML Parser Errors
> See Details for more Information
> XML Parser Error on line 8: Attribute "generatorSet" must be declared for
> element type "abatorContext".
>
> Is this a known bug? Is ther any workaround?
>
> --
> Koen De Jaeger
>

Mime
View raw message