ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From j-lists <jamisonli...@gmail.com>
Subject Re: ibatis, XML and special characters
Date Sun, 18 Mar 2007 13:05:41 GMT
I would guess that this is a database encoding problem, have you
confirmed that the ">"s are causing a problem or just the non-ascii
characters? If the driver is getting generating invalid UTF16 for Java
(internally) that might be causing the failure... unfortunately this
is a real pain to debug and fix. Bulk loaders can fill varchars with
badly encoded text that give trouble.

Just a theory.
-J

On 3/12/07, Yuvraj Shinde <Yuvraj.Shinde@sos.sungard.com> wrote:
>
>
>
>
> You can use CDATA tag.
>
>
>
>  ________________________________
>
>
> From: Ashish Kulkarni [mailto:ashish.kulkarni13@gmail.com]
>  Sent: Monday, March 12, 2007 5:47 AM
>  To: user-java@ibatis.apache.org
>  Subject: ibatis, XML and special characters
>
>
>
>
> Hi
>  I am using ibatis to run a SQL statement which returns a XML as output as
> shown below,
>
>  <select id="getItemSpeicalNotes" resultClass="xml"
> parameterClass="java.math.BigDecimal"
> xmlResultName="ITEMSPECIALNOTES">
>          SELECT P706DETL as SPECIALNOTE , PDLINE as PDLINENOTES FROM PU1706,
> PU1013 WHERE P706ORD = PDPORD and PDSPEC = P706SPEC and PDPORD = #value#
> order by P706LINE
>      </select>
>
>
>  I am having issues when the data returned by SQL statement has special
> characters like > or umlots ΓΌ,
>  how do i handle this, is there a way to tell ibatis to parse these special
> characters and make it XML complaint before creating XML result
>
>  Ashish

Mime
View raw message