ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Diran Ayandele <Adediran.Ayand...@Sun.COM>
Subject Re: Properties not loaded after first null (sometimes)
Date Tue, 15 Aug 2006 20:54:06 GMT
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
  <title></title>
</head>
<body bgcolor="#ffffff" text="#000099">
Juan, <br>
&nbsp;&nbsp;&nbsp; Not enough details in your note to be sure, but this may be
a
driver problem.&nbsp; I have seen similar things working with different
versions of oracle databases and drivers. <br>
<br>
Diran<br>
<br>
Juan Alvarez wrote:
<blockquote
 cite="mid20060815202349.15654.qmail@web37502.mail.mud.yahoo.com"
 type="cite">
  <style type="text/css"><!-- DIV {margin:0px} --></style>
  <div
 style="font-family: courier,monaco,monospace,sans-serif; font-size: 10pt;">
  <div>
  <div>Hi,</div>
  <div>&nbsp;</div>
  <div>I'm suffering some really strange phenomenon with Ibatis
(2.1.6.589). In some of my maps I discovered that when a particular
field came with a null valued from the database, all the properties
that where defined after that one in the map, where not feeded with the
values retrieved from the database. I checked not only in the database
itself but also with a network sniffer that the values where really
coming. Magically if I place the conflicting property as the last in
the map, the rest took values properly. This begun with some date typed
fields and the workaround served me, but now I've come across the same
behaviour with other data types and I'm fearing I cannot trust what I
get from the database through Ibatis.</div>
  <div>&nbsp;</div>
  <div>Please help me as I'm forced into Ibatis by customer requirement
and.</div>
  <div>&nbsp;</div>
  <div>Regards</div>
  </div>
  </div>
</blockquote>
</body>
</html>

Mime
View raw message