ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Clinton Begin" <clinton.be...@gmail.com>
Subject Re: Crazy error using Ibatis 2.1.7 (defaultStatementTimeout)
Date Sun, 27 Aug 2006 02:31:22 GMT
Can you share the insane stack trace?  That would help.  :-)

The DTD did change for 2.2.0, but it should be backward compatible with
2.1.7, as the defaultStatementTimeout attribute is #IMPLIED.  So it is
optional.

One possibility is that it's your IDE telling you that the
defaultStatementTimeout
"must" be there (which it does not), and by putting it there iBATIS 2.1.7 is
failing because it's using the DTDs inside the JAR at runtime - which
doesn't recognize the attribute.

Cheers,
Clinton


On 8/26/06, Jonathan Prater <jonathan.prater@gmail.com> wrote:
>
>  OK, I put together an IBATIS config file including a <settings />
> element.  The DTD tells me there has to be a defaultStatementTimeout
> attribute in there, so I put one in, saying defaultStatementTimeout="5".  My
> project compiled perfectly, so I tried to run it.  I got a
> huge-ugly-monster-type stack trace from an exception thrown that said
> defaultStatementTimeout was required for the settings element.  I could not
> get it to pick up the defaultStatementTimeout no matter how I changed the
> format of the settings element.  I finally just dropped the element
> altogether and now the program runs like a top.  What gives?!  Is this some
> weird crazy known bug in 2.1.7?
>
> Jon, who is totally freaked out by this insane error :P
>

Mime
View raw message