ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Butler" <jeffgbut...@gmail.com>
Subject Re: public int executeBatch()
Date Tue, 30 May 2006 22:36:28 GMT
The JIRA patch suggests a new method name of "executeBatchDetailed".  That
sounds reasonable.

I propose that we discuss this issue in JIRA and see if we can come to some
agreement about how it should work.

I think the JIRA patch is a good starting point towards working on a
solution to this.  rs - if you have further suggestions please add them to
the JIRA issue (for example, what do you mean by "return code"?  1/0?
SQLCode?  SQLState?).
Jeff Butler

On 5/30/06, Sven Boden <list123@pandora.be> wrote:
> I know some people that do use it... I try to make everything as
> backwards compatible as possible. So since java doesn't differentiate on
> return type personally I would use another name for the "fixed"
> executeBatch. The people already using the current version don't have to
> change, and you can use the new name if you want to use the new
> functionality.
> Upgrades should just be about replacing the jars files... but that's
> probably just me dreaming.
> Sven
> rs wrote:
> >
> >
> >>Personally, because it would break stuff for some people currently using
> >>executeBatch.
> >>
> >>
> >
> >You mean if they upgrade to the next release without reading the release
> notes or ignoring the compatibility issues? That kind of danger exists for
> any release.
> >
> >I doubt many people use executeBatch() though, for it has major problems,
> in my opinion: if one or more records fail, currently there is no way to
> find out
> >1) which records failed
> >2) why they failed
> >
> >Additionally, all "good" records will be rolled back.
> >
> >

View raw message