ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nathan Maves <Nathan.Ma...@Sun.COM>
Subject Re: Upgrade Problem iBATIS 1.3.1 -> iBATIS 2.1.7
Date Wed, 03 May 2006 15:22:01 GMT
Andre,

Some of the methods did change in the 2.x conversion.

Can you please post your actual code to the alias so that we can help  
you better.

I would like to see your dao config class.

Nathan

On May 3, 2006, at 9:09 AM, Andre.Gerhartz@SV-Informatik.de wrote:

> Hello,
>
> I have problems updating to iBATIS 2.1.7. (We use Java 1.5)
>
> i 've replaced following jars:
>
> - ibatis-common.jar
> - ibatis-dao.jar
> - ibatis-sqlmap.jar
> - ibatis-sqlmap-1-x.jar (added)
>
> Following compile-errors occure (Eclipse SDK 3.1.2, MyEclipse 4.1.1):
>
> --------
>
> The method rollbackTransaction() is undefined for the type DaoManager
> AngebotBL.java
>
> The method getInstance(String) is undefined for the type DaoManager
>
> The method getDao(Class, String) in the type DaoManager is not  
> applicable
> for the arguments (String)
>
> The method getLocalTransaction() is undefined for the type DaoManager
>
> The method getCurrentLocalConnection() is undefined for the type
> SqlMapClient
>
> The method setCurrentDataSourceName(String) is undefined for the type
> SqlMap
>
> The method getDataSource() in the type SqlMap is not applicable for  
> the
> arguments (String)
>
> The method configure(Reader) is undefined for the type DaoManager
>
> --------
>
> Does anybody know a solution for these problems ?
>
>
> Greetings,
> Andre
>


Mime
View raw message