ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clinton Begin <clinton.be...@gmail.com>
Subject Re: [VOTE] Discontinue Support for: iBATIS Java 1.x, JDK 1.3 and DTDs at ibatis.com
Date Sun, 06 Nov 2005 23:18:31 GMT
I have to agree with Vic.

The beauty of a version control system, and good version control practices,
is that we shouldn't be afraid to break out of our dependency shell.

I've already tagged 2.1.6, so we can branch it any time. The next version
going out will be 2.2.0, so there's even room for 3 more "official" versions
(or more if we break the version convention).

So...it's not like we're leaving the JDK 1.3 people out in the cold.
Honestly, we've gone just about as far as we can with JDK 1.3.

Dare I say: "The needs of the many, outweigh the needs of the few?"

Isn't it unfair to my loyal 87%, to stay on JDK 1.3?

Cheers,
Clinton

On 11/6/05, netsql <netsql@roomity.com> wrote:
>
> They can continue to use older versions of iBatis, it does not stop.
> iBatis is solid today, even 1.0 is solid.
> Also you have the source, so you can compile and fix as you see fit.
>
>
> .V
>
> Paul Benedict wrote:
> > I vote in favor for all except ending support for JDK
> > 1.3 - earlier versions fine, but 1.3 is important.
> > Wait until you go release 3.0 because major version
> > changes should be able to break backwards
> > compatibility in a major way, but not minor releases.
> > Suddenly switching between 2.1 and 2.3 I think is
> > really unfair to your loyal 13% customer base. My 2
> > cents.
> >
> >
> >
> >
> >
> > __________________________________
> > Yahoo! Mail - PC Magazine Editors' Choice 2005
> > http://mail.yahoo.com
> >
>
>
> --
> thx,
> .V
>
> Your Roomity Broadband Community <http://roomity.com/demo.jsp>
>
> cell: 917 825 3035 in DFW
> email: netsql at roomity.com <http://roomity.com>
>
>

Mime
View raw message