ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clinton Begin <clinton.be...@gmail.com>
Subject Re: [VOTE] Discontinue Support for: iBATIS Java 1.x, JDK 1.3 and DTDs at ibatis.com
Date Sun, 06 Nov 2005 23:00:32 GMT
They're already on apache.org <http://apache.org>!

http://ibatis.apache.org/dtd/

Cheers,
Clinton

On 11/6/05, Larry Meadors <lmeadors@apache.org> wrote:
>
> I am not sure i understand: Will the iBATIS 1.x DTDs remain where they
> are, go away (potentially a very, very bad thing), or get moved to
> apache.org <http://apache.org>?
>
> Larry
>
>
> On 11/5/05, Clinton Begin <clinton.begin@gmail.com> wrote:
> > Hi everyone:
> >
> > == What? ==
> >
> > I'm going to raise a vote and recommend to discontinue support for:
> >
> > * iBATIS 1.x (including 2.0 compat package)
> > * All JDKs 1.3 and earlier (and therefore old JDBC versions)
> > * DTDs hosted by iBATIS.com
> >
> > == Why? ==
> >
> > I'm basing my recommendations on the following facts:
> >
> > Only 3% of iBATIS users use iBATIS 1.x.
> > Only 13% of iBATIS users use JDK 1.3.1 or earlier
> > We serve up 1.4 million copies of our DTD every month from
> > ibatis.com....which is costing me money. :-)
> >
> > Discontinuing support for these will allow us to move forward with more
> new
> > features and lighten the code up a bit.
> >
> > == When? ==
> >
> > iBATIS 1.x support ends as of version 2.2.0 (next feature release)
> > JDK 1.3 and earlier versions support ends as of version 2.2.0 (next
> feature
> > release)
> > DTDs hosted at iBATIS.com removed by November 30th 2005 as per the
> > warning[1] that went out in September (90 days notice).
> >
> > To be proactive, pragmatic and practical, we will tag the SVN repository
> at
> > version 2.1.6 (next bug fix release). This version can then be branched
> if
> > necessary to fix any critical issues for those living in Bedrock.
> >
> > == Who? ==
> >
> > Would all PMC members please vote on the three items individually
> >
> > ( ) iBATIS 1.x is unsupported as of version 2.2.0
> > ( ) JDK 1.3 and earlier are unsupported as of version 2.2.0
> > ( ) DTDs hosted at iBATIS.com are removed as of November 30th, 2005.
> >
> > Everyone else is free to comment. If you think your business will be
> > significantly impacted by this, please let us know.
> >
> > Cheers,
> >
> > Clinton
> >
> >
> > [1]
> > http://www.mail-archive.com/user-java@ibatis.apache.org/msg01333.html
> >
> >
>

Mime
View raw message