ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clinton Begin <clinton.be...@gmail.com>
Subject Re: Caching (please help)
Date Sat, 05 Nov 2005 20:47:20 GMT
Unfortunately, in order for it to cache, I believe you need a parameter. We
could consider that a bug, albeit rare. But try adding a dummy parameter to
test it.

Cheers,
Clinton

On 11/5/05, Paul Benedict <paul4christ79@yahoo.com> wrote:
>
> I've spent the last two weeks trying to get the
> caching to work, but I can confirm iBATIS is not
> caching any result I configure it for. Obviously this
> isn't anyone else's problem but mine, but I really
> feel hopeless here and don't know what else to do.
>
> Here is my cache:
> <cacheModel id="namesCache" type="MEMORY">
> <flushInterval hours="24"/>
> <flushOnExecute statement="insertName"/>
> <flushOnExecute statement="updateName"/>
> <property name="reference-type" value="STRONG"/>
> </cacheModel>
>
> Here is my select:
> <select id="getNames" resultMap="idMap"
> cacheModel="namesCache">
> SELECT id, name FROM names
> </select>
>
> I have LOG4J turned on for the iBATIS package and I
> can always see it getting a connection, a prepared
> statement, and the result set. So I know it's not
> caching. I just call getNames() over and over and it
> never caches.
>
> I am using Spring. I know caching is enabled by
> default, so I don't have any special settings in my
> sql-config.xml. I am bummed out. Can you spot anything wrong?
>
>
>
>
> __________________________________
> Yahoo! Mail - PC Magazine Editors' Choice 2005
> http://mail.yahoo.com
>

Mime
View raw message