ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clinton Begin <clinton.be...@gmail.com>
Subject Supported JDK Version
Date Tue, 30 Aug 2005 04:51:25 GMT
Hi everyone,

It's always been the iBATIS policy to support the current JDK version, and 
one previous version. However, we've been supporting JDK 1.3 and JDBC
2.0for some time simply because it wasn't a problem.

We're now at a point whereby there is enough legacy JDK 1.3 and JDBC
2.0code that we can consider it a problem. More importantly though, we
haven't
been able to fully realize the benefits of JDBC 3.0 as much as we'd like to. 


Furthermore, the breakdown of iBATIS users using the various JDK versions is 
as follows:

1.4 - 69.93%
1.5 - 18.66%
1.3 - 11.40%

So there is nearly 90% of the user population that could be taking greater 
advantage of JDBC 3.0 features, while also eliminating "overhead" code 
that's there to deal with JDBC 2.0. 

So, in a way this email is an advanced warning that JDK 1.3 and JDBC
2.0will no longer be supported (we'll announce the version that will
mark the
end of such support).

On the other hand, this email is a call out to anyone who has a major 
problem with this.....if you have a reason why we shouldn't ditch JDK
1.3and/or JDBC
2.0, then please speak up. Although, reasons like "IBM hasn't updated their 
driver since JDK 1.0.1" likely won't help your cause much. ;-)

Cheers,
Clinton

Mime
View raw message