ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Larry Meadors <larry.mead...@gmail.com>
Subject Re: Problem with BLOB and iBatis 2.0.9b, Oracle 8, Oracle 10g JDBC Drivers
Date Tue, 12 Apr 2005 21:40:44 GMT
Cool, thanks for the solution.

Larry

On Apr 12, 2005 3:39 PM, Paul Barry <paul.barry@nyu.edu> wrote:
> 
> Explicitly setting jdbcType="BLOB" on the resultMap seems to have done
> the trick, OCI vs. thin has nothing to do with it.
> 
> Paul Barry wrote:
> > I just tried installing Oracle 10g Instant Client to use OCI. I changed
> > the URI to "jdbc:oracle:oci:@myhost:1521:mysid", but I still get just 86
> > bytes.
> >
> > Paul Barry wrote:
> >
> >> I am using iBatis 2.0.9b talking to an Oracle database. Here the
> >> specific database version:
> >>
> >> Oracle8i Enterprise Edition Release 8.1.7.0.0 - 64bit Production
> >>
> >> Did some googling on using BLOBs with iBATIS and Oracle, and found 
> this:
> >>
> >> 
> http://www.mail-archive.com/ibatis-dev@incubator.apache.org/msg00517.html
> >>
> >> So I went here and downloaded the Oracle 10g JDBC drivers:
> >>
> >> 
> http://www.oracle.com/technology/software/tech/java/sqlj_jdbc/index.html
> >>
> >> So, I have an object with a byte[] property. When I map the result of
> >> a query that has a BLOB in it to this propery, the length always
> >> returns 86. Am using "oracle.jdbc.driver.OracleDriver" driver type
> >> and "jdbc:oracle:thin:@myhost:1521:mysid" for the URI. Should this
> >> work, or is there something else I need to do to get this to work?
>

Mime
View raw message