ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brandon Goodin <brandon.goo...@gmail.com>
Subject Re: Exception Help
Date Fri, 25 Feb 2005 23:01:11 GMT
Did you change xml parsers? What xml parser are you using?

Brandon

On Fri, 25 Feb 2005 13:00:17 -0700, Averill Cate, Jr.
<acate@email.arizona.edu> wrote:
> I am new to iBATIS and like what I have seen just by implementing iBATIS
> into a struts app I am working on.  I used to tutorial to build features
> into the app that allow me to save a registering user to a database.
> The application works until I change the sql-map-config.xml file then I
> keep getting an exception with the following error:
> 
> Caused by: java.lang.RuntimeException: Error initializing SQLConfig
> class. Cause: com.ibatis.common.exception.NestedRuntimeException: Error
> occurred.  Cause: com.ibatis.common.xml.NodeletException: Error parsing
> XML.  Cause: org.xml.sax.SAXParseException: Content is not allowed in
> prolog.
> Caused by: org.xml.sax.SAXParseException: Content is not allowed in prolog.
> Caused by: com.ibatis.common.xml.NodeletException: Error parsing XML.
> Cause: org.xml.sax.SAXParseException: Content is not allowed in prolog.
> Caused by: org.xml.sax.SAXParseException: Content is not allowed in prolog.
> 
> My sql-map-config.xml is as follows:
> 
> <?xml version="1.0" encoding="UTF-8"?>
> <!DOCTYPE sqlMapConfig
>    PUBLIC "-//iBATIS.com//DTD SQL Map Config 2.0//EN"
>    "http://www.ibatis.com/dtd/sql-map-config-2.dtd">
>   <sqlMapConfig>
>  <transactionManager type="JDBC">
>    <dataSource type="SIMPLE">
>      <property name="JDBC.Driver" value="oracle.jdbc.driver.OracleDriver"/>
>      <property name="JDBC.ConnectionURL"
> value="jdbc:oracle:thin:@localhost:1521:MAIN"/>
>      <property name="JDBC.Username" value="test"/>
>      <property name="JDBC.Password" value="test"/>
>    </dataSource>
>  </transactionManager>
> 
>  <sqlMap resource="dotagwa/xml/User.xml"/>
>  <sqlMap resource="dotagwa/xml/ManagementPlan.xml"/>
>  </sqlMapConfig>
> 
> The problem started when I added the sqlMap ManagementPlan.  I removed
> the line from my xml file, but that did fix things and the error shows
> up in all actions that try to use iBATIS.  Has anyone seen this before
> or know why it may be happening?  Thanks for any help!
> 
>

Mime
View raw message