ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clinton Begin <clinton.be...@gmail.com>
Subject Re: Strange problems with Custom Type Handler
Date Thu, 20 Jan 2005 22:12:01 GMT
Question: Why haven't you specified a JDBC type in either case? 
That's probably the root of the problem.


On Thu, 20 Jan 2005 14:51:19 -0700, Nathan Maves <Nathan.Maves@sun.com> wrote:
> Yes,  It made no difference.
> 
> Remember that it DOES work for me on my development machine.  Just not
> against my production table.  I am using the same jar's and the same
> code just changing the DB url.
> 
> NOT WORKING
> SQL> desc rv_report_hierarchy;
>   Name                                      Null?    Type
>   ----------------------------------------- --------
> ----------------------------
>   REPORT_ID                                 NOT NULL NUMBER(12)
>   PARENT_ID                                          NUMBER(12)
>   REPORT_NAME                               NOT NULL VARCHAR2(100)
>   FREQUENCY_ID                                       NUMBER(1)
>   DESCRIPTION                                        VARCHAR2(1000)
>   REPORT_TYPE                               NOT NULL NUMBER(2)
>   ARCHIVE_IND                               NOT NULL NUMBER(1)
>   BRIO_JOB_ID                                        NUMBER(6)
>   POSTED_DATE                                        DATE
>   HIERARCHY_CODE                                     VARCHAR2(25)
>   REPORT                                             BLOB
>   INFOPARTNER_IND                                    NUMBER(1)
>   CATEGORY                                           VARCHAR2(30)
>   LAST_UPDATE_DATE                                   DATE
> 
> WORKING
> SQL> desc rv_report_hierarchy;
>   Name                                      Null?    Type
>   ----------------------------------------- --------
> ----------------------------
>   REPORT_ID                                 NOT NULL NUMBER(12)
>   PARENT_ID                                          NUMBER(12)
>   REPORT_NAME                               NOT NULL VARCHAR2(100)
>   FREQUENCY_ID                                       NUMBER(1)
>   DESCRIPTION                                        VARCHAR2(1000)
>   REPORT_TYPE                               NOT NULL NUMBER(2)
>   ARCHIVE_IND                               NOT NULL NUMBER(1)
>   INFOPARTNER_IND                                    NUMBER(1)
>   BRIO_JOB_ID                                        NUMBER(12)
>   POSTED_DATE                                        DATE
>   LAST_UPDATE_DATE                                   DATE
>   HIERARCHY_CODE                                     VARCHAR2(25)
>   REPORT                                             BLOB
>   CATEGORY                                           VARCHAR2(100)
> 
> 
> On Jan 20, 2005, at 2:35 PM, Clinton Begin wrote:
> 
> > Did you try putting the cth reference where I suggested?
> >
> > Clinton
> >
> > On Thu, 20 Jan 2005 14:33:44 -0700, Nathan Maves
> > <Nathan.Maves@sun.com> wrote:
> >> here is my latest getter in the CTH
> >>
> >>      public Object getResult(ResultGetter getter) throws SQLException
> >> {
> >>          if (getter.wasNull())
> >>              return null;
> >>          int value = getter.getInt();
> >>          Frequency frequency = Frequency.get(value);
> >>          return frequency;
> >>      }
> >>
> >> when I run the query from sqlplus I get a 1 for the frequency_id
> >> field.
> >>
> >> but in the code above I get a value of 0 from the getter object.
> >>
> >> Nathan
> >>
> >> On Jan 20, 2005, at 2:16 PM, Nathan Maves wrote:
> >>
> >>> I tried that just now and not change.
> >>>
> >>>
> >>> On Jan 20, 2005, at 2:01 PM, Clinton Begin wrote:
> >>>
> >>>> <result column="frequency_id" property="frequency"
> >>>> typeHandler="reporting.viewer.dao.ibatis.FrequencyTypeHandler"/>
> >>>
> >>
> >>
> 
>

Mime
View raw message