ibatis-user-cs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Terry Austin" <taus...@progressivepartnering.com>
Subject RE: Mono and Sql Server Provider
Date Wed, 04 Jul 2007 16:07:04 GMT
Never mind.  False alarm.  My providers.config literally had a space in the
type name for the SqlCommandBuilder reference - notice the space at the
beginning of the type name in the error message below.
 
Terry Austin
Progressive Partnering
 

________________________________

From: Terry Austin [mailto:taustin@progressivepartnering.com] 
Sent: Tuesday, July 03, 2007 10:34 AM
To: user-cs@ibatis.apache.org
Subject: Mono and Sql Server Provider


I can't get IBatis.Net to load the MS Sql Server provider named
'sqlServer2.0' in the provider.config file when running under Mono on
Windows.  I'm thinking that I'm doing something wrong and I have some
fundamental misunderstanding of the Mono environment.  If anyone has any
experience with it and can give me some pointers, I would appreciate it.
 
The (shortened) error is basically: Unable to load provider named
"sqlServer2.0" not found, failed. Cause: Could not load type '
System.Data.SqlClient.SqlCommandBuilder'. ---> System.TypeLoadException:
Could not load type ' System.Data.SqlClient.SqlCommandBuilder'
 
I'm using a stock install of the latest Mono distribution installed on
Windows XP SP2.  Of course, everything works correctly when ran using the MS
runtime - the error only occurs when executing using mono.exe to run the
process.
 
Any help or thoughts would be appreciated.
 
Terry Austin
Progressive Partnering


Mime
View raw message