ibatis-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sven.Boden" <list...@pandora.be>
Subject Re: iBATIS Junit tests setup
Date Mon, 03 Oct 2005 11:42:45 GMT

I'm currently using JDK 1.4.2_06 on windows. I found some results on internet suggesting to
upgrade to JDK 1.5. To me for the moment it looks like somehow the testcases are just not
in the classpath when executing the build script (I did an extract of SVN, and didn't change
any file afterwards).

I will try some more (and possibly upgrade or downgrade the JDK) ;-)... I thought someone
else might already have had the problem.


>Wow... What JVM/SDK are you using?
>On 10/1/05, Sven Boden <list123@pandora.be> wrote:
>> Been playing with the following for an hour but can't seem to get it
>> solved. When I extract iBATIS from SVN and run the build script all
>> JUnit tests fail in the following way:
>> java.lang.ClassNotFoundException:
>> com.ibatis.common.resources.ResourcesTest at
>> java.net.URLClassLoader$1.run(URLClassLoader.java:199) at
>> java.security.AccessController.doPrivileged(Native Method) at
>> java.net.URLClassLoader.findClass(URLClassLoader.java:187) at
>> java.lang.ClassLoader.loadClass(ClassLoader.java:289) at
>> java.lang.ClassLoader.loadClass(ClassLoader.java:235) at
>> java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302) at
>> java.lang.Class.forName0(Native Method) at
>> java.lang.Class.forName(Class.java:141)
>> I guess this has something to do with the java.policy file, but I
>> can't seem to figure out which entries to add. Can someone give me a
>> pointer?
>> Regards,
>> Sven

View raw message