httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Eissing <stefan.eiss...@greenbytes.de>
Subject Re: [users@httpd] acme-challenge folder exists but 404 contents
Date Mon, 07 Jan 2019 08:42:46 GMT
This sounds as if you have loaded "mod_md" and it has taken over the /.well-known/acme-challenge
folder. This was a bug in that module which has been fixed in subsequent releases.

If you do not use mod_md, the easiest remedy is to not load it into your server.
If you want to use mod_md together with other Lets Encrypt clients such as certbot, you need
to upgrade to a recent Apache httpd version or get the module from github and compile it yourself.

Hope this helps,

Stefan

> Am 02.01.2019 um 14:36 schrieb Jens-U. Mozdzen <jmozdzen@nde.ag>:
> 
> Hi Jerry,
> 
> Zitat von Jerry Malcolm <techstuff@malcolms.com>:
>> I have an apache install that has been up and running for months.  I use LetEncrypt
for certificates.  I went to renew all of my certificates using an automated script that worked
fine 3 months ago on the last refresh.  It failed on every domain saying the challenge file
was not found.  I put a test.html file in /.well-known/acme-challenge folder, and tried to
access it with a browser, and it gave me a 404.  After moving the test.html file around into
other folders, it was found correctly in every folder except acme-challenge. [...]
> 
> what's in the Apache logs? The access log should report the 404, is there anything related
in the error logs?
> 
> Regards,
> J
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message