httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Cox <j...@jeffpcox.com>
Subject Re: [users@httpd] Configuring redirects from http to https
Date Fri, 30 Nov 2018 20:27:35 GMT
Try it like this.  This is mine except my server name and server alias are
reversed.

<VirtualHost *:80>
    ServerName www.abc.com
    ServerAlias abc.com
    Redirect 301 / https://www.abc.com/
</VirtualHost>

--
Jeff Cox
jeff@jeffpcox.com



On Fri, Nov 30, 2018 at 1:40 PM Jack M. Nilles <jnilles@jala.com> wrote:

> I tried adding trailing slashes as follows, but the result was the same: a
> 111 error. Did I misinterpret your comment?
>
> # http redirect
>>> <VirtualHost aaa.bbb.ccc.ddd:80>
>>>  ServerName www.host1.com
>>>  ServerAlias host1.com *.host1.com
>>>    Redirect "/" "https://www.host1.com/" # Here
>>> </VirtualHost>
>>>
>>> <Virtualhost *:80>
>>>  ServerName www.host2.com
>>>  ServerAlias host2.com *.host2.com
>>>    Redirect / https://www.host2.com/ # and here
>>> </VirtualHost>
>>>
>>> # https versions
>>> <VirtualHost aaa.bbb.ccc.ddd:443>
>>>   ServerAdmin . . .
>>>   ServerName www.host1.com
>>>   ServerAlias . . .
>>> . . .
>>>
>>
>>> On 29 Nov 2018, at 15:12, Frank Gingras <thumbs@apache.org> wrote:
>
> The (111) is a networking issue because you're not matching the trailing
> slashes with your redirects.
>
> On Thu, Nov 29, 2018 at 6:06 PM Jonathon Koyle <litereader@gmail.com>
> wrote:
>
>> Can you reproduce the issue and provide some logs, and maybe more
>> information about the actual response?  the 1xx range isn't supposed to be
>> an error code in HTTP.
>>
>> On Thu, Nov 29, 2018 at 3:25 PM Jack M. Nilles <jnilles@jala.com> wrote:
>>
>>> I have the following configuration file covering two virtual hosts:
>>>
>>> # http redirect
>>> <VirtualHost aaa.bbb.ccc.ddd:80>
>>>  ServerName www.host1.com
>>>  ServerAlias host1.com *.host1.com
>>>    Redirect "/" "https://www.host1.com"
>>> </VirtualHost>
>>>
>>> <Virtualhost *:80>
>>>  ServerName www.host2.com
>>>  ServerAlias host2.com *.host2.com
>>>    Redirect / https://www.host2.com
>>> </VirtualHost>
>>>
>>> # https versions
>>> <VirtualHost aaa.bbb.ccc.ddd:443>
>>>   ServerAdmin . . .
>>>   ServerName www.host1.com
>>>   ServerAlias . . .
>>> . . .
>>>
>>> The https parts work well but if people try to get http://host1.com or
>>> http://host2.com they get connection (111) errors indicating that the
>>> redirects aren't working. I've tried different versions of the redirects --
>>> with and without double quotes -- and it doesn't seem to make a difference.
>>>
>>> How to I get the redirects to function?
>>>
>>
>>
>> --
>> Jonathon Koyle
>>
>
>

Mime
View raw message