httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vincent Veyron <vv.li...@wanadoo.fr>
Subject Re: [users@httpd] apache 2.4 and mod_perl2
Date Mon, 19 Mar 2018 17:33:36 GMT
On Tue, 27 Feb 2018 10:37:55 -0500
David Mehler <dave.mehler@gmail.com> wrote:

I'm late on this, but just in case :

> 
> I'm trying to get apache 2.4 and mod_perl2 in my case 2.0.10 going on
> a FreeBSD 11.1 system.
> 
> I've got this in a virtual host section:
> 
> Alias "/perlweb/" "/usr/local/www/perlweb/"
> <Location "/perlweb/">
>       AddHandler perl-script .pl
>       AddHandler perl-script .cgi
>       PerlResponseHandler ModPerl::Registry
>       PerlOptions +ParseHeaders
>       Options +ExecCGI
> Require all granted
> </Location>
> 
> 
> 
> I'm getting a syntax error on the PerlResponseHandler line invalid command.
> 

http://perl.apache.org/docs/2.0/user/intro/start_fast.html#Registry_Scripts

Note the line that says 'SetHandler perl-script' vs your 'AddHandler perl-script .pl'



> Anyone got any ideas how I can fix?
> 

The mod_perl list certainly has one; you should try there.

http://perl.apache.org/maillist/modperl.html

-- 
					Bien à vous, Vincent Veyron 

https://compta.libremen.com
Logiciel libre de comptabilité générale en partie double

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message