httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "jose cabrera" <jic...@mail.com>
Subject Re: [users@httpd] Can't install apache2 in ubntu after an uninstall
Date Thu, 22 Feb 2018 02:47:22 GMT


> >It's a rather terrible idea to post a link without much context.
Apologies.

  
> To make it worse, that forum post is without much substance that would help us fix your
problem. Start with the relevant error log entries.

If I run,

/usr/sbin/apachectl -t -D DUMP_MODULES 

here is the result:

root@GBRTEF01LX005:/var/www/html/bugzilla# /usr/sbin/apachectl -t -D DUMP_MODULES 
 /usr/sbin/apachectl: 175: /usr/sbin/apachectl: /usr/sbin/apache2: not found 
 Action '-t -D DUMP_MODULES' failed. 
 The Apache error log may have more information.

When I go to the /var/log/apache2/error.log, it's empty.  And the origin of all of this is
that I had to move a running bugzilla version from Windows into Ubuntu. I had the a fresh
installation of bugzilla running yesterday, but when I tried to bring the data in, the css
and scripts where not displaying the site correctly. I tried setting the owner and user of
the files and directories, I found that apache was having rights issues. I tried getting help
from bugzilla, but no one replied with the correct fix. I thought that if I remove apache
and install it back, it would fix the security problems. Well, was I wrong...!

I have tried a good 4-5 times to,

sudo apt-get purge apache2 apache2-utils apache2.2-bin apache2-common
sudo apt-get autoremove
whereis apache2

and then used

sudo rm -rf /etc/apache2 

on any directory that resulted from the whereis command. Now, I can not install apache2 on
the system. Help.  So, even though, it appears as if it was installed, there is no /usr/sbin/apache2.
 Thoughts?  Thanks.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message