httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Covener <cove...@gmail.com>
Subject Re: [users@httpd] Apache httpd directory listing no longer working
Date Wed, 14 Feb 2018 12:33:01 GMT
On Wed, Feb 14, 2018 at 3:05 AM,  <stefaan.dutry@roularta.be> wrote:
> Directory listing inside one of our VirtualHost configurations has stopped working recently.
> It now returns a 403 Forbidden when trying to access a directory.
>
> The url is protected with basic authentication from a .htpasswd file.
> Accessing a specific file under de location presents no problem. => not a problem
with the .htpasswd file
> The directory listing used to work with this configuration.
>
> Is there some other configuration that needs to be checked?
>
> The configuration is as follows.
>
> <VirtualHost *>
>     Servername my.servername.com
> ...
>     Alias /mydirectory / "/my/actual/location"

mismatch trailing slash a potential red flag her.

what URL fails and what's the verbatin error_log entry?

> ...
>     <Location /mydirectory>

better as <Directory> here

>         Options +Indexes
>         AuthName "Restricted access"
>         AuthUserFile /etc/httpd/conf/my.htpasswd
>         AuthType Basic
>         require valid-user
>     </Location>
> </VirtualHost>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message