httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yann Ylavic <ylavic....@gmail.com>
Subject Re: [users@httpd] Receiving only 8000 bytes in CGI programs using post method
Date Tue, 07 Nov 2017 13:04:07 GMT
Hi,

On Tue, Nov 7, 2017 at 12:27 PM, Ramon Loureiro <braga_ramon@hotmail.com> wrote:
>
> Here is the brief description of the problem we are in.

Which cgi module is used on httpd? mod_proxy_fcgi, mod_fcgi?

>
> When we use the Apache server to service non-secure web pages (server
> running on port 8086) all bytes are sent to CGI programs during the
> publishing method. Always returns response 200, and does not return response
> 413. But the CGI only reads 8000 bytes, and the rest is not read.

Did you take a network trace between httpd and the backend (pcap with
wireshark or tcpdump)?
Are the remaining bytes actually sent by httpd or not?

>
> When we use the same server with secure web pages running on port 443, the
> CGI reads all blocks other than the first 8000 bytes.

I don't see how (for now) it could depend on the client's side type of
connection (TLS or not).
The dumpio traces show that in both cases the whole content is
received by httpd, so let's see with network traces whether it's been
sent on the other side.


Regards,
Yann.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message