httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Norbert <ngrun...@uni-muenster.de>
Subject [users@httpd] Question about apache2.4, prefork and mod_perl
Date Wed, 13 Sep 2017 07:11:19 GMT
Hello,

I hope this request is not stupid, but I did not find anything which 
gives me an answer...

So: I am running apache 2.4 (on FreeBSD 11), use mod_perl and prefork.  
When the server starts it creates several httpd processes all running 
under root.  This is ok.  When a request arrives it creates subprocesses 
with the user www:www (80:80) - everything ok.  But now the question: 
why are the processes with www:www user terminated after a short time / 
request?  Meaning: if I wait a short time, the mod_perl modules have 
allways been "reinitailized", as far as I can so from my debugging 
output. Is there a way to keep a fixed number of processes under www:www 
running - at least for hours?  I hope I could explain...

the neccessary part of my httpd.conf is:

...
LoadModule mpm_prefork_module libexec/apache24/mod_mpm_prefork.so
...
<IfModule unixd_module>
User www
Group www
</IfModule>
...
PerlRequire /path/to/startup.pl
PerlModule ModPerl::PerlRun
PerlModule ModPerl::Registry
...

thanks for help!  Norbert



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message