httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fabio F.Gervasi" <fabio.gervas...@gmail.com>
Subject Re: [users@httpd] Apache responds in https, but only by test page, not my website
Date Sun, 13 Aug 2017 09:07:00 GMT
Sorry, maybe did you mean https -S...

[root@servercm master]# httpd -S
AH00112: Warning: DocumentRoot [/home/web/dancemusicawards.ru] does not
exist
AH00112: Warning: DocumentRoot [/home/web/www.dancemusicawards.ru] does not
exist
[Sun Aug 13 11:01:53.899753 2017] [alias:warn] [pid 27571:tid
139691180570816] AH00671: The Alias directive in
/etc/httpd/conf.d/phpMyAdmin.conf at line 8 will probably never match
because it overlaps an earlier Alias.
[Sun Aug 13 11:01:53.899875 2017] [alias:warn] [pid 27571:tid
139691180570816] AH00671: The Alias directive in
/etc/httpd/conf.d/phpMyAdmin.conf at line 9 will probably never match
because it overlaps an earlier Alias.
VirtualHost configuration:
*:80                   is a NameVirtualHost
         default server centrometeo.com (/etc/httpd/conf/httpd.conf:470)
         port 80 namevhost centrometeo.com (/etc/httpd/conf/httpd.conf:470)
         port 80 namevhost dancemusicawards.ru
(/etc/httpd/conf/httpd.conf:479)
         port 80 namevhost www.dancemusicawards.ru
(/etc/httpd/conf/httpd.conf:485)
*:443                  is a NameVirtualHost
         default server centrometeo.com (/etc/httpd/conf.d/ssl.conf:56)
         port 443 namevhost centrometeo.com (/etc/httpd/conf.d/ssl.conf:56)
         port 443 namevhost centrometeo.com (/etc/httpd/conf/httpd.conf:491)
ServerRoot: "/etc/httpd"
Main DocumentRoot: "/home/web"
Main ErrorLog: "/etc/httpd/logs/error_log"
Mutex lua-ivm-shm: using_defaults
Mutex fcgid-proctbl: using_defaults
Mutex ssl-stapling: using_defaults
Mutex proxy: using_defaults
Mutex authn-socache: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir="/run/httpd/" mechanism=default
Mutex cache-socache: using_defaults
Mutex fcgid-pipe: using_defaults
Mutex rewrite-map: using_defaults
Mutex ssl-stapling-refresh: using_defaults
PidFile: "/run/httpd/httpd.pid"
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
Define: MODPERL2
User: name="apache" id=48
Group: name="apache" id=48

Maybe there is soma problem about ssl.conf?


2017-08-12 19:18 GMT+02:00 Fabio F.Gervasi <fabio.gervasi70@gmail.com>:

> I try to run:
>
> [root@servercm httpd]# apachectl -S
>
> but it does not return anything...
>
>
> 2017-08-12 19:07 GMT+02:00 Eric Covener <covener@gmail.com>:
>
>> On Sat, Aug 12, 2017 at 12:47 PM, Fabio F.Gervasi
>> <fabio.gervasi70@gmail.com> wrote:
>> > Hi Eric, thank you.
>> >
>> > I'm not expert, I did not understand what to do... Regarding logs, I
>> > defined:
>> >
>> > <VirtualHost *:443>
>> >     ServerAdmin fabio.gervasi@centrometeo.com
>> >     DocumentRoot /home/web/centrometeo.com
>> >     ServerName centrometeo.com
>> >     ErrorLog logs/https-centrometeo.com-error_log
>> >     CustomLog logs/https-centrometeo.com-access_log common
>> > </VirtualHost>
>> >
>> > So, using differents name/files, but after a few attempts to access via
>> > https, empty files were created, so there is nothing in the logs.
>>
>> That means you have another virtualhost handling your port 443 traffic.
>>
>> apachectl -S will summarize where your vhosts are defined if you can't
>> find them with grep or an editor.
>>
>>
>> --
>> Eric Covener
>> covener@gmail.com
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>> For additional commands, e-mail: users-help@httpd.apache.org
>>
>>
>

Mime
View raw message