httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Deepak Kumar <deepak...@gmail.com>
Subject [users@httpd] Apache 2.4.12 to 2.4.26 upgrade on AIX 6.1
Date Tue, 25 Jul 2017 20:36:15 GMT
Hi,
I am new to Apache on AIX. We have a system where Apache 2.4.12 has been
installed on AIX 6.1. I need to upgrade it to latest 2.4.26. Looks like the
previous install was an RPM based install.
I need some help with upgrading Apache.

1. What is the best process to upgrade to Apache 2.4.26. Can I use compile
method instead of RPM which I am familiar with?
2. If I download latest RPM's from IBM and install them, will it not
overwrite the existing apache installation in /opt/freeware...
3. In Aix looks like apache install files will be in /opt/freeware under
several different directories. /opt/freeware will also have non-apache
related libs/files. How to take backups of previous install in these
directories if I have to restore if new install fails.
4. Following is a list of RPM's that were previously installed. Based on
this list can you let me know what all rpm's will be required for apache
2.4.26 upgrade?


*Last installed RPM's list:*

httpd-2.4.12-1
pcre-devel-8.36-1
pcre-8.36-1
apr-util-1.5.4-1
apr-util-ldap-1.5.4-1
apr-1.5.1-1
sqlite-devel-3.7.6.3-3
sqlite-3.7.6.3-3
openldap-devel-2.4.35-1
openldap-2.4.35-1
gdbm-devel-1.8.3-2
gdbm-1.10-1
freetds-devel-0.92.79-1
freetds-0.92.79-1
gnutls-2.12.20-1
nettle-2.7-2
gmp-5.1.3-1
libtasn1-3.3-1
lzo-2.06-2
p11-kit-0.14-1
libgcrypt-1.5.0-1
libgpg-error-1.10-3
unixODBC-devel-2.3.1-1
unixODBC-2.3.1-1
expat-devel-2.1.0-1
expat-2.1.0-1
db-devel-4.8.24-4
db-4.8.24-4
pkg-config-0.25-3
openssl-devel-1.0.1l-1
openssl-1.0.1l-1
AIX-rpm-6.1.8.15-3

--
Thanks & Regards,
Deepak Kumar

Mime
View raw message