httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Covener <cove...@gmail.com>
Subject Re: [users@httpd] need help
Date Sat, 08 Jul 2017 20:42:07 GMT
On Sat, Jul 8, 2017 at 3:42 PM,  <rss@poruokis.lt> wrote:
> I want to compile httpd with --with-mpm=event module loaded dynamically but
> I'm getting a fault below after starting httpd service.
>
> Invalid command 'MinSpareServers', perhaps misspelled or defined by a module
> not included in the server configuration
>
>
> My compile script:
>
> configure_flags="                                               \
>         --prefix=/etc/httpd                                     \
>         --exec-prefix=/etc/httpd                                \
>         --bindir=/usr/bin                                       \
>         --sbindir=/usr/sbin                                     \
>         --libexecdir=/usr/lib64/apache                          \
>         --sysconfdir=/etc/httpd/conf                            \
>         --datadir=/var/www                                      \
>         --includedir=/usr/include/apache                        \
>         --localstatedir=/var                                    \
>         --mandir=/usr/share/man                                 \
>         --with-mpm=event                                        \
>         --enable-mods-static=most                               \
>         --enable-ssl=shared                                     \
>         --enable-suexec                                         \
>         --enable-unique-id                                      \
>         --with-pcre                                             \
>         --with-suexec-caller=apache                             \
>         --with-suexec-logfile=/dev/null                         \
>         --with-suexec-uidmin=1000                               \
>         --with-suexec-gidmin=1000                               \
>         --with-suexec-umask=022"
>
> ./configure $configure_flags --with-suexec-docroot=/home

I'm not sure how you ended up with worker.  You're missing
--enable-mpms-shared= so you should have a statically linked event
mpm.

Maybe config.log has some error?

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message