httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Covener <cove...@gmail.com>
Subject Re: [users@httpd] Apache 2.4.12 to 2.4.26 upgrade on AIX 6.1
Date Tue, 25 Jul 2017 21:39:19 GMT
On Tue, Jul 25, 2017 at 4:36 PM, Deepak Kumar <deepakwsa@gmail.com> wrote:
> Hi,
> I am new to Apache on AIX. We have a system where Apache 2.4.12 has been
> installed on AIX 6.1. I need to upgrade it to latest 2.4.26. Looks like the
> previous install was an RPM based install.
> I need some help with upgrading Apache.
>
> 1. What is the best process to upgrade to Apache 2.4.26. Can I use compile
> method instead of RPM which I am familiar with?

You can build your own or use someone else's RPMs (IBM or the
third-party sites that produce AIX RPMS of OSS)

> 2. If I download latest RPM's from IBM and install them, will it not
> overwrite the existing apache installation in /opt/freeware...

Presumably

> 3. In Aix looks like apache install files will be in /opt/freeware under
> several different directories. /opt/freeware will also have non-apache
> related libs/files. How to take backups of previous install in these
> directories if I have to restore if new install fails.

This seems like overkill, but couldn't you just use tar?  All of the
OSS RPM's use /opt/freeware.

> 4. Following is a list of RPM's that were previously installed. Based on
> this list can you let me know what all rpm's will be required for apache
> 2.4.26 upgrade?

I doubt you will find this help from a peer, when rpm can tell you the
dependencies on your own system.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message