httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rockzOr <m...@rockzor.de>
Subject Re: [users@httpd] ownCloud / PHP-FPM problem after upgrade to 2.4.26
Date Tue, 27 Jun 2017 20:42:59 GMT
Hi Jacob,

thanks for your very quick answer!

I just want to confirm, that I'm facing this issue. I haven't tested it 
with 2.4.25, but with your provided directive.

Without the directive I get:

[Tue Jun 27 22:33:09.126391 2017] [proxy_fcgi:trace8] [pid 10358:tid 
140239523075840] mod_proxy_fcgi.c(419): [client 
2a02:908:694:bd00:39c2:29c4:625d:3a88:49821] AH01062: sending env var 
'SCRIPT_NAME' value '/v1.php'

and with ProxyFCGIBackendType on GENERIC I get:

[Tue Jun 27 22:35:08.976942 2017] [proxy_fcgi:trace8] [pid 13665:tid 
140239523075840] mod_proxy_fcgi.c(419): [client 
2a02:908:694:bd00:39c2:29c4:625d:3a88:49830] AH01062: sending env var 
'SCRIPT_NAME' value '/ocs/v1.php'

For now I leave it with set to GENERIC as it fixes my issue and I can't 
face any other problems. As I only set it in my ownCloud vhost, nothing 
else is changed by this.

So thanks a lot for pointing me to this (have searched but didn't find 
that) and good luck on fixing it for 2.4.27! Is there a plan for 
releasing 2.4.27 as for the broken behaviour or will it be next regular 
release in X months?

Regards,

Am 27.06.2017 um 22:23 schrieb Jacob Champion:
> On 06/27/2017 12:48 PM, rockzOr wrote:
>> Hi all,
>>
>> I've got a problem after upgrading to 2.4.26. Everything works fine 
>> except my ownCloud instance.
>
> Fair warning: I haven't looked through all of the info you provided 
> (but thank you for being thorough!). FPM problems after upgrading to 
> 2.4.26 are almost certainly due to bug 61202 [1], which we are working 
> on now.
>
> You can verify that this is your problem by adding "proxy_fcgi:trace8" 
> to your LogLevel, finding the log entry that says "AH01062: sending 
> env var 'SCRIPT_NAME'", and comparing the value of SCRIPT_NAME we now 
> send in 2.4.26 to the one that we sent in 2.4.25. If they're different 
> -- typically the 2.4.26 value is left-truncated -- then this is most 
> likely your bug.
>
> If you need a quick fix, and you know 2.4.25 worked for you, you can 
> return to the 2.4.25 behavior by using the directive 
> "ProxyFCGIBackendType GENERIC". This isn't a viable fix for everyone, 
> because it breaks other FPM configurations that used to work prior to 
> 2.4.21. We're working on reverting to the 2.4.20 behavior by default 
> and filling out the test suite so we don't break you again.
>
> I'm sorry for the inconvenience, and thanks for your patience.
>
> --Jacob
>
> [1] https://bz.apache.org/bugzilla/show_bug.cgi?id=61202
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message