httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel <dferra...@gmail.com>
Subject Re: [users@httpd] I need help figuring out a 500 response code
Date Wed, 03 May 2017 13:08:35 GMT
Perhaps you should also add how you are configuring httpd to handle the
interpretation of PHP files.

That is, if you are, for example using mod_proxy_fcgi to send php file
requests to php-fpm you should see your 500 detailed errors there instead
of Apache.

Apache will always log 500status errors, so maybe you should make sure you
are checking the correct login if you are not using the case I describe
above.

If you are using the dreaded mod_php you should check for php directives
you can specify for more verbose logging onto why your php scripts fail.

I use owncloud too, so if you want I can show you a configuration snippet
on how to set apache with mod_proxy_fcgi reverse proxy php requests to a
php-fpm pool

2017-05-03 11:21 GMT+02:00 John Covici <covici@ccs.covici.com>:

> The error_log just had one line or in debug mode a lot of information
> about ssl and several lines about requireall granted, but no further
> information about the error.
>
> On Wed, 03 May 2017 02:55:28 -0400,
> Dr James Smith wrote:
> >
> > Is there an error.log in the same directory? This is usually in
> > the same directory this should contain some information about why
> > the system failed.
> >
> >
> > On 03/05/2017 07:41, John Covici wrote:
> > > Hi.  I am having major problems figuring out a 500 response code I am
> > > getting  on my hserver.
> > >
> > > I am using apache 2.4.25 on gentoo linux up to date as of a few days
> > > ago.
> > >
> > > So, I havinstalled owncloud which is a cloud server written in php and
> > > it has worked for a long time, but for a few days I have gotten 500
> > > when I try to access it.  Now, I am using https normally to access and
> > > when I look at the error_log, I get just one line like this:
> > >
> > > [Wed May 03 02:14:37.074791 2017] [ssl:info] [pid 22312] [client
> > > 192.168.0.2:56613] AH01964: Connection to child 0 established (server
> > > ccs.covici.com:443)
> > >
> > > If I change the loglevel to debug, I get all kinds of ssl information
> > > and the lines saying that requireall was granted, but nothing about
> > > the error.
> > >
> > > Now, if I change to http access, on my access_log I get lines like the
> > > following:
> > >
> > > 192.168.0.2 - - [03/May/2017:02:33:38 -0400] "GET /owncloud HTTP/1.1"
> > > 301 295
> > > 192.168.0.2 - - [03/May/2017:02:33:38 -0400] "GET /owncloud HTTP/1.1"
> > > 301 295 "-" "Mozilla/5.0 (Windows NT 10.0; WOW64; Trident/7.0;
> > > rv:11.0) like Gecko"
> > > 192.168.0.2 - - [03/May/2017:02:33:38 -0400] "GET /owncloud HTTP/1.1"
> > > 301 295 "-" "Mozilla/5.0 (Windows NT 10.0; WOW64; Trident/7.0;
> > > rv:11.0) like Gecko"
> > > 192.168.0.2 - - [03/May/2017:02:33:38 -0400] "GET /owncloud/ HTTP/1.1"
> > > 302 -
> > > 192.168.0.2 - - [03/May/2017:02:33:38 -0400] "GET /owncloud/ HTTP/1.1"
> > > 302 - "-" "Mozilla/5.0 (Windows NT 10.0; WOW64; Trident/7.0; rv:11.0)
> > > like Gecko"
> > > 192.168.0.2 - - [03/May/2017:02:33:38 -0400] "GET /owncloud/ HTTP/1.1"
> > > 302 - "-" "Mozilla/5.0 (Windows NT 10.0; WOW64; Trident/7.0; rv:11.0)
> > > like Gecko"
> > > 192.168.0.2 - - [03/May/2017:02:33:38 -0400] "GET
> > > /owncloud/index.php/login HTTP/1.1" 500 -
> > > 192.168.0.2 - - [03/May/2017:02:33:38 -0400] "GET
> > > /owncloud/index.php/login HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows NT
> > > 10.0; WOW64; Trident/7.0; rv:11.0) like Gecko"
> > > 192.168.0.2 - - [03/May/2017:02:33:38 -0400] "GET
> > > /owncloud/index.php/login HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows NT
> > > 10.0; WOW64; Trident/7.0; rv:11.0) like Gecko"
> > >
> > > Now, owncloud has theirownw log, but I get nothing in it.
> > >
> > > So, my question is how to find out more about why I am getting the 500
> > > response and what I can do about it.
> > >
> > > Thanks in advance for any suggestions.
> > >
> >
> >
> >
> > --
> > The Wellcome Trust Sanger Institute is operated by Genome
> > Research Limited, a charity registered in England with number
> > 1021457 and a company registered in England with number 2742969,
> > whose registered office is 215 Euston Road, London, NW1 2BE.
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> > For additional commands, e-mail: users-help@httpd.apache.org
> >
>
> --
> Your life is like a penny.  You're going to lose it.  The question is:
> How do
> you spend it?
>
>          John Covici
>          covici@ccs.covici.com
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>


-- 
*Daniel Ferradal*
IT Specialist

email         dferradal at gmail.com
linkedin     es.linkedin.com/in/danielferradal

Mime
View raw message