httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luca Toscano <toscano.l...@gmail.com>
Subject Re: [users@httpd] http/2 vs. Headername
Date Tue, 23 May 2017 09:36:22 GMT
Hi Hajo,

any chance that you could download/build/test the latest release of
https://github.com/icing/mod_h2/releases ?

Luca

2017-05-23 11:30 GMT+02:00 Hajo Locke <Hajo.Locke@gmx.de>:

> Hello,
>
> no one has an idea? Currently i believe this is a kind of apache bug.
> I compiled curl with http2 Support to view more debugdetails:
>
> curl -v --http2 https://example.com/
>
> *   Trying ip.ip.ip.ip...
> * Connected to example.com (ip.ip.ip.ip) port 443 (#0)
> * found 173 certificates in /etc/ssl/certs/ca-certificates.crt
> * found 696 certificates in /etc/ssl/certs
> * ALPN, offering h2
> * ALPN, offering http/1.1
> * SSL connection using TLS1.2 / ECDHE_RSA_AES_128_GCM_SHA256
> *        server certificate verification OK
> *        server certificate status verification SKIPPED
> *        common name: example.com (matched)
> *        server certificate expiration date OK
> *        server certificate activation date OK
> *        certificate public key: RSA
> *        certificate version: #3
> *        subject: CN=example.com
> *        start date: Mon, 22 May 2017 05:04:00 GMT
> *        expire date: Sun, 20 Aug 2017 05:04:00 GMT
> *        issuer: C=US,O=Let's Encrypt,CN=Let's Encrypt Authority X3
> *        compression: NULL
> * ALPN, server accepted to use h2
> * Using HTTP2, server supports multi-use
> * Connection state changed (HTTP/2 confirmed)
> * TCP_NODELAY set
> * Copying HTTP/2 data in stream buffer to connection buffer after upgrade:
> len=0
> * Using Stream ID: 1 (easy handle 0x55c2a77b4bd0)
> > GET / HTTP/1.1
> > Host: example.com
> > User-Agent: curl/7.47.0
> > Accept: */*
> >
> * Connection state changed (MAX_CONCURRENT_STREAMS updated)!
> * HTTP/2 stream 1 was not closed cleanly: error_code = 1
> * Closing connection 0
> curl: (16) HTTP/2 stream 1 was not closed cleanly: error_code = 1
>
> Same problem as in webbrowsers.
> problem can be avoided by disabling http2 modul or by removing Headername
> from .htaccess. Both is not intended.
> Somebody can confirm this problem?
>
> Thanks,
> Hajo
>
>
> Am 22.05.2017 um 09:22 schrieb Hajo Locke:
>
> Apache 2.4.25
>
> Hello,
>
> i have a small .htaccess with following content to view Foldercontents:
> ###
> Options +Indexes
> Headername /foo/bar.htm
> ###
> This is working by http, but fails in https if browser uses http/2.
> Chrome Message: ERR_SPDY_PROTOCOL_ERROR
> Firefox: Secure Connection Failed
>
> I dont see any error in my logs, http/2 Browsers just stop loading.
> When disabling http/2, also https is working.
> What to do now?
>
> Thanks,
> Hajo
>
>
>

Mime
View raw message