httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From KASPAR Sandro <sandro.kas...@hsr.ch>
Subject Re: [users@httpd] cgi script error output logging
Date Wed, 17 May 2017 15:07:44 GMT
To make sure it is not an OS specific problem I tested the same on ubuntu 16.04 with apache2.4.18
and mod_fcgid 2.3.9. Same problem there.


If you have any other ideas I could try I would appreciate it.


Sandro

________________________________
From: KASPAR Sandro <sandro.kaspar@hsr.ch>
Sent: Wednesday, May 17, 2017 3:08:18 PM
To: users@httpd.apache.org
Subject: Re: [users@httpd] cgi script error output logging



Hi Petr,


Thank you for your help. I tried your tests on [1]. I tested everything wiht apache 2.4.25
and mod_fcgid 2.3.9 and apache 2.4.25 and mod_cgi. In both cases I get the same behaviour.
Everything sent to stderr, in this case "I am an ERROR", is written to the apache error log
without any further information. No timestamp etc. So my log looks like this:


...

I am an ERROR
I am an ERROR
I am an ERROR
[Wed May 17 14:52:22.653661 2017] [mpm_worker:notice] [pid 1274:tid 34401707008] AH00295:
caught SIGTERM, shutting down
[Wed May 17 14:52:22.839149 2017] [mpm_worker:notice] [pid 1430:tid 34401707008] AH00292:
Apache/2.4.25 (FreeBSD) mod_fcgid/2.3.9 configured -- resuming normal operations
[Wed May 17 14:52:22.839503 2017] [core:notice] [pid 1430:tid 34401707008] AH00094: Command
line: '/usr/local/sbin/httpd -D NOHTTPACCEPT'
I am an ERROR

I tried this with apache default configuration, except for enabling mod_cgi or mod_fcgid.
Did you have to configure anything special to get more information on the log lines?

Sandro


[1] https://github.com/pgajdos/apache-rex/blob/master/mod_cgi-stderr/run.sh


________________________________
From: Petr Gajdos <pgajdos@suse.cz>
Sent: Friday, May 12, 2017 10:37:17 AM
To: users@httpd.apache.org
Subject: Re: [users@httpd] cgi script error output logging

On Fri, May 12, 2017 at 09:16:29AM +0200, Petr Gajdos wrote:
> Hi,
>
> On Thu, May 11, 2017 at 08:07:28AM +0000, KASPAR Sandro wrote:
> > Hi suomi,
> >
> >
> > Thank you for your answer. Unfortunately I am not using php-fpm but fcgid. As
>
> JFYI, simple example [0] had shown that for me it does work with
> mod_cgi (tested with 2.4.25).

So I tried [1] also with httpd 2.4.25 and apache2-mod_fcgid 2.3.9 and
it seem to work for me,  if I understand correctly. The spec file
%check is a bit hard to read (work in progress), but I can provide you
%with minimal httpd.conf, if you wish.

Petr

[1] (search for APACHE MODULE TEST)
    https://build.opensuse.org/package/live_build_log/Apache:Modules/apache2-mod_fcgid/openSUSE_Tumbleweed/x86_64
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message