httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Iliffe <john.ili...@iliffe.ca>
Subject Re: [users@httpd] Getting PHP-FPM working
Date Tue, 16 May 2017 16:05:06 GMT
Hi Eric:

I'm a bit slow-witted I guess, in any event, I now have strace installed 
and I ran it to get the attached trace file.

It's seems to me that the problem is in the call:   (about 250 lines before 
the end of the file at time stamp 11:39:16)

18767 11:39:16 lstat("/httpd/iliffe/i_phpinfo.php/info", 0x7fff1d6b4f90) = -1 
ENOTDIR (Not a directory)

where the path information from the initial call is being appended to the 
correct path information in the second parameter of ProxyPassMatch.  (???) 

FYI, the configuration directive is:

ProxyPassMatch ^/info$ fcgi://127.0.0.1:9015/httpd/iliffe/i_phpinfo.php

so I don't understand why this would happen. 

So, over to you.

Regards,

John
========================================

On Sunday 14 May 2017 11:42:53 Eric Covener wrote:
> On Sat, May 13, 2017 at 11:01 PM, John Iliffe <john.iliffe@iliffe.ca> wrote:
> > Sure:
> > 
> > ----------------------
> > # namei -m /httpd/iliffe/i_phpinfo.php
> > f: /httpd/iliffe/i_phpinfo.php
> > 
> >  dr-xr-xr-x /
> >  drwxr-xr-x httpd
> >  drwxr-xr-x iliffe
> >  -rw-r--r-- i_phpinfo.php
> > 
> > ----------------------
> 
> There's something odd  about that code/logging (no parameter on the
> open call repesenting the name!) Can you strace the FPM process and
> see what it actually tries to open?
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org

Mime
View raw message