httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luca Toscano <toscano.l...@gmail.com>
Subject Re: [users@httpd] Looking for direction: porting server from Apache 2.2.2 to 2.4.6 - ProxyHTMLURLMap ?
Date Thu, 27 Apr 2017 08:09:31 GMT
Hi Jeff,

2017-04-26 19:35 GMT+02:00 Jeff Cauhape <jpcauhape@nvdetr.org>:

> Hi,
>
>
>
> I’ve been given the task of moving a website from Apache 2.2.2 on Solaris
> to Apache 2.4.6 on Linux.
>
>
>
> So far, so good, but I’m running into a ‘syntax’ error when a config file
> uses the ProxyHTMLURLMap
>
> function. Apache 2.4.6 does not recognize this, and I don’t have the
> module (proxy_html_module /
>
> mod_proxy_html.so) required to support it.
>
>
>
> So… should I substitute calls to ProxyHTMLURLMap to some other function in
> 2.4.6 (if so which),
>
> or if not, where can I get the compiled function or source code?  From my
> take on the doc, proxy_html_module
>
> is supposed to be available, but is not included. It would be handy to
> know where I can get the source
>
> and compile my own, if that’s the way to go.
>
>
>
> Thanks in advance for any tips or suggestions,
>

mod_proxy_html is included in the official httpd release so you can easily
find it in https://httpd.apache.org. I think that your distribution might
offer it under a separate package, but it is difficult to say without more
info.

Hope that helps!

Luca

>

Mime
View raw message