httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mitchell Krog Photography <mitchellk...@gmail.com>
Subject RE: [users@httpd] Hiding Apache version info on the Aix server for Apache.
Date Thu, 16 Mar 2017 07:09:15 GMT
I’ve tested on CentOS 6.8, Apache 2.2.15

Both

*ServerTokens PROD*
*ServerSignature Off*

Work perfectly and do not affect the starting of the server.

Secondly have you actually ever run a configtest?

*apachectl configtest*

If you copy and paste the the ServerTokens and ServerSignature lines above
exactly as I have them they will work. If not then you have messed up
something else in your httpd.conf file which is why a configtest is so
important.

I attach a very basic httpd.conf which you can try, it’s as basic as it
gets.

Regards
Mitchell



From: Chunduru, Krishnachaithanya
<krishnachaithanya.chunduru@broadridge.com>
<krishnachaithanya.chunduru@broadridge.com>
Reply: users@httpd.apache.org <users@httpd.apache.org>
<users@httpd.apache.org>
Date: 15 March 2017 at 3:05:15 PM
To: users@httpd.apache.org <users@httpd.apache.org> <users@httpd.apache.org>
Subject:  RE: [users@httpd] Hiding Apache version info on the Aix server
for Apache.

Hi,

Below are the entries I have updated in the httpd.conf and tried restarting
the apache, but it didn't started and didn't even gave any errors.

$cat /etc/httpd/conf/httpd.conf | grep -i signature
ServerSignature Off

$ cat /etc/httpd/conf/httpd.conf | grep -i tokens
ServerTokens Prod

Regards,
Krishna


-----Original Message-----
From: Konstantin Kolinko [mailto:knst.kolinko@gmail.com]
Sent: Wednesday, March 15, 2017 1:24 PM
To: users@httpd.apache.org
Subject: Re: [users@httpd] Hiding Apache version info on the Aix server for
Apache.

2017-03-14 14:56 GMT+03:00 Chunduru, Krishnachaithanya
<Krishnachaithanya.Chunduru@broadridge.com>:
> Hi All,
>
>
>
> Can anyone please let me know how to hide the apache version and the
> OS name running on Aix server.
>
>
>
> The servertokens or the server signature fields are set to PROD and
> signature off, then I tried restarting the httpd but apache was not
> starting until these two parameters are removed from the config file.

Thus your edits have an effect. Good.

What are the actual lines, and what was the actual error message?

Check you spelling. Copy-paste from documentation, if possible.

Try to search if other configuration files define those directives.
(The files included into main httpd.conf file with "Include" directive).


Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


This message and any attachments are intended only for the use of the
addressee and may contain information that is privileged and confidential.
If the reader of the message is not the intended recipient or an authorized
representative of the intended recipient, you are hereby notified that any
dissemination of this communication is strictly prohibited. If you have
received this communication in error, please notify us immediately by
e-mail and delete the message and any attachments from your system.
B‹KKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKCB• È
[œÝXœØÜšX™K K[XZ[ ˆ \Ù\œË][œÝXœØÜšX™P ˜\ XÚ K›Ü™ÃB‘›Üˆ Y
] [Û˜[ ÛÛ[X[™ Ë
K[XZ[ ˆ \Ù\œËZ [ ˜\ XÚ K›Ü™ÃB

Mime
View raw message