httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremy Maes <jeremy.m...@cipalschaubroeck.be>
Subject [users@httpd] Mod_dav configuration question
Date Thu, 09 Mar 2017 08:17:26 GMT
Hi

Since a few months we're using WebDAV (apache mod_dav) to serve files 
for one of our apps. Everything works alright but when combined with an 
older WebDAV client (needed for Office 2010 and older) we're running 
into some issues.

The company that made the client has looked into the problem and gives 
this as a possible cause for our issues:

> You WebDAV server returns path without domain in href. For example <D:href>/GOLF/</D:href>
instead of <D:href>http://server/GOLF/</D:href>. This may not work with some mini-redirector

> versions, especially with older Windows versions.
When we check the traffic with Fiddler it seems mod_dav is indeed 
returning relative paths instead of the full path. I've searched the 
documentation for an option that might force the use of full paths but 
couldn't find one. Does anybody have an idea if such an option exists or 
how I'd be able to force this behavior?

We're running on RHEL6 (apache 2.2.15), using mod_dav. Specific webdav 
config file:

> Listen 44595
>
> <VirtualHost *:44595>
>         DocumentRoot /shares/webdav
>
>         <IfModule mod_dav.c>
>                 LimitXMLRequestBody 131072
>
>                 <Directory /shares/webdav/>
>                         Order Allow,Deny
>                         Allow from all
>
>                         Dav On
>                         Options -Indexes
>                         AllowOverride None
>                         AddDefaultCharset UTF-8
>                 </Directory>
>         </IfModule>
> </VirtualHost>

Thanks in advance for any insights.

-- 
Kind regards,
Jeremy



 **** DISCLAIMER ****
http://www.cipalschaubroeck.be/disclaimer

Mime
View raw message