httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Iliffe <john.ili...@iliffe.ca>
Subject [users@httpd] Unable to start apache-2.4.25; missing ssl module
Date Tue, 21 Mar 2017 02:32:21 GMT
I hate to re-ask a question that I have asked before (in 2012) but I have a 
new version of Apache and the same problem again.

I compiled Apache-2.4.25 from source, and also openssl-1.0.2k.  In the 
Apache configuration I included  "--with-ssl=/usr/openssl-1.0.2k" but now  
when I try to start apache using apachectl -k start I get the following 
error:

--------------------
httpd: Syntax error on line 135 of /usr/apache-2.4.25/conf/httpd.conf: 
Cannot load modules/mod_ssl.so into server: libcrypto.so.1.0.0: cannot open 
shared object file: No such file or directory
---------------------

Without SSL there isn't a problem; Apache starts just fine.

OK, so I'm cool, I look up the archive from the last time this happened and 
it says to provide the path to the library in the Apache envvars file so I 
did that.  There are two envvars files, envvars-std and envvars so I updatd 
them both.  No luck.

So, I decided to provide the path directly and I set up these two links in 
the apache/lib directory:

lrwxrwxrwx.  1 root root      33 Mar 20 22:09 libssl.so ->  
						 /usr/openssl-1.0.2k/lib/libssl.so
lrwxrwxrwx.  1 root root      39 Mar 20 22:11 libssl.so.1.0.0 ->
						 /usr/openssl-1.0.2k/lib/libssl.so.1.0.0

Still no luck.  Both of the linked files are present. 

OS is Fedora 25 with SELinux running in permissive mode.

Can anyone see what I missed?

Regards,

John
====================================


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message