httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Iliffe <john.ili...@iliffe.ca>
Subject Re: [users@httpd] Error nghttp2 version is too old
Date Fri, 17 Mar 2017 00:24:06 GMT
I solved this one and it had nothing to do with the version of the nghttp 
library.

I did not have the development environment for nghttp installed.  

Installing libnghttp2-devel.x86_64 resolved the problem and the compilation 
ran to completion.

[The following applies specifically to Fedora 25; I don't know if it is 
applicable to other current distros.]

For what it's worth, this is the second time I have got caught this way on 
this project.  Last time it was pcre.  Installing the programme using dnf 
(replacement for rpm/yum) doesn't also install the development components, 
if any.  You can find out if any exist by running 'dnf search name'  and if 
name-devel exists it will be listed.

Regards,

John
==========================================
On Wednesday 15 March 2017 03:32:49 Konstantin Kolinko wrote:
> The source code:
> 
> https://svn.apache.org/viewvc/httpd/httpd/branches/2.4.x/modules/http2/c
> onfig2.m4?revision=1779742&view=markup#l124
> 
> > AC_MSG_CHECKING([for nghttp2 version >= 1.2.1])
> 
> Just prints the "Checking..." message. The actual check is below -
> compilation of some snippet.
> 
> > AC_TRY_COMPILE([#include <nghttp2/nghttp2ver.h>],[
> 
> If compilation and test succeed then the following assignment happens:
> "ac_cv_nghttp2=yes".
> 
> 
> Apparently the compilation and test failed, and the variable was not
> assigned.
> 
> The following block
> 
> > if test "x$ac_cv_nghttp2" = "xyes"; then
> > [ a lot of lines checking capabilities and setting some flags ]
> > else
> > 
> >   AC_MSG_WARN([nghttp2 version is too old])
> > 
> > fi
> 
> The "if" branch was skipped and "else" branch printed the warning.
> 
> 
> I suggest you to check what is the actual value of NGHTTP2_VERSION_NUM.
> 
> > checking for user-provided nghttp2 base directory...
> 
> Try to specify the path explicitly,
>   --with-nghttp2=PATH
> 
> 2017-03-15 2:15 GMT+03:00 John Iliffe <john.iliffe@iliffe.ca>:
> > I'm not sure it is evident that there is a question buried in the 
notehttp --enable-proxy-fcgi --enable-http2 --with-nghttp2 --enable-info 
> > below so here is a precis of what I asked:
> > 
> > 1.  the requirement is for nghttp2 at level 1.2.1 whereas I have
> > nghttp2 1.13.0 installed.  Why is that considered lower than the
> > requirement?
> > 
> > 2.  assuming (always a bad idea) that the problem is that the compiler
> > is checking for some specific link in the nghttp2 library, is it
> > likely that what I really need to do is install a back level, and if
> > so, any idea what it is looking for?  ..or what back level is
> > required?
> > 
> > Sorry for the confusion.
> > 
> > John
> > ====================================
> > 
> > On Tuesday 14 March 2017 10:25:27 you wrote:
> >> OK, I will have to see what I can do with Fedora, probably not much
> >> in this case.
> >> 
> >> My question though was that the version I have is 1.13.0 according to
> >> rpm. That would seem to be higher than 1.2.1 so why would the
> >> compiler complain? I assume that it has an internal requirement on
> >> the library that it didn't find?
> >> 
> >> In that case it might be necessary to back off a few levels to find
> >> whatever the compiler wants?
> >> 
> >> Regards,
> >> 
> >> John
> >> =================================
> >> 
> >> > On Tuesday 14 March 2017 02:39:23 you wrote:
> >> > > You really need to approach your package maintainer, I picked up
> >> > > nghttp2 around that same point a year ago and never had an issue.
> >> > > 
> >> > > Anything to do with rpm installs is on the maintainer, and has
> >> > > nothing to do with this project, sorry we can't be of more help.
> >> > > 
> >> > > On Sun, Mar 12, 2017 at 3:12 PM, John Iliffe
> >> > > <john.iliffe@iliffe.ca>
> >> 
> >> wrote:
> >> > > > I am trying to compile Apache 2.4.25 on Fedora 25 Linux.
> >> > > > 
> >> > > > The current version of nghttp2 is installed:
> >> > > > 
> >> > > > -----------------------------
> >> > > > [John@prod04 httpd-2.4.25]$ rpm -qv nghttp2
> >> > > > nghttp2-1.13.0-2.fc25.x86_64
> >> > > > -----------------------------
> >> > > > 
> >> > > > -----------------------------
> >> > > > /usr/lib64/libnghttp2.so.14
> >> > > > /usr/lib64/libnghttp2.so.14.9.0
> >> > > > -----------------------------
> >> > > > 
> >> > > > To me, these would both seem to be greater than 1.2.1, but I
am
> >> > > > getting this error from configure:
> >> > > > 
> >> > > > ----------------------------------------------
> >> > > > checking for nghttp2... checking for user-provided nghttp2 base
> >> > > > directory... none
> >> > > > checking for pkg-config along ... checking for nghttp2 version
> >> > > > >= 1.2.1... FAILED
> >> > > > configure: WARNING: nghttp2 version is too old
> >> > > > no
> >> > > > checking whether to enable mod_http2... configure: error:
> >> > > > mod_http2 has been requested but can not be built due to
> >> > > > prerequisite failures
> >> > > > ------------------------------------------------
> >> > > > 
> >> > > > These are the currently available versions from the Fedora
> >> > > > repository.
> >> > > > 
> >> > > > Has anyone any suggestions as to why this might be occurring?
> >> > > > 
> >> > > > Thanks in advance.
> >> > > > 
> >> > > > John
> >> > > > ===================================
> >> > > > 
> >> > > > ---------------------------------------------------------------
> >> > > > --- -- - To unsubscribe, e-mail:
> >> > > > users-unsubscribe@httpd.apache.org For additional commands,
> >> > > > e-mail: users-help@httpd.apache.org
> > 
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> > For additional commands, e-mail: users-help@httpd.apache.org
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message