httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Iliffe <john.ili...@iliffe.ca>
Subject Re: [users@httpd] Error nghttp2 version is too old
Date Tue, 14 Mar 2017 14:25:27 GMT

OK, I will have to see what I can do with Fedora, probably not much in
this case.
 
My question though was that the version I have is 1.13.0 according to
rpm. That would seem to be higher than 1.2.1 so why would the compiler
complain? I assume that it has an internal requirement on the library
that it didn't find?

In that case it might be necessary to back off a few levels to find
whatever the compiler wants?

Regards,

John
=================================
> 
> On Tuesday 14 March 2017 02:39:23 you wrote:
> > You really need to approach your package maintainer, I picked up
> > nghttp2 around that same point a year ago and never had an issue.
> > 
> > Anything to do with rpm installs is on the maintainer, and has nothing
> > to do with this project, sorry we can't be of more help.
> > 
> > On Sun, Mar 12, 2017 at 3:12 PM, John Iliffe <john.iliffe@iliffe.ca> 
wrote:
> > > I am trying to compile Apache 2.4.25 on Fedora 25 Linux.
> > > 
> > > The current version of nghttp2 is installed:
> > > 
> > > -----------------------------
> > > [John@prod04 httpd-2.4.25]$ rpm -qv nghttp2
> > > nghttp2-1.13.0-2.fc25.x86_64
> > > -----------------------------
> > > 
> > > -----------------------------
> > > /usr/lib64/libnghttp2.so.14
> > > /usr/lib64/libnghttp2.so.14.9.0
> > > -----------------------------
> > > 
> > > To me, these would both seem to be greater than 1.2.1, but I am
> > > getting this error from configure:
> > > 
> > > ----------------------------------------------
> > > checking for nghttp2... checking for user-provided nghttp2 base
> > > directory... none
> > > checking for pkg-config along ... checking for nghttp2 version >=
> > > 1.2.1... FAILED
> > > configure: WARNING: nghttp2 version is too old
> > > no
> > > checking whether to enable mod_http2... configure: error: mod_http2
> > > has been requested but can not be built due to prerequisite failures
> > > ------------------------------------------------
> > > 
> > > These are the currently available versions from the Fedora
> > > repository.
> > > 
> > > Has anyone any suggestions as to why this might be occurring?
> > > 
> > > Thanks in advance.
> > > 
> > > John
> > > ===================================
> > > 
> > > --------------------------------------------------------------------
> > > - To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> > > For additional commands, e-mail: users-help@httpd.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message