httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yann Ylavic <ylavic....@gmail.com>
Subject Re: [users@httpd] mod_lua and subprocess_env
Date Wed, 22 Feb 2017 13:36:06 GMT
On Wed, Feb 22, 2017 at 11:19 AM, Andrei Ivanov <andrei.ivanov@gmail.com> wrote:
> On Wed, Feb 22, 2017 at 12:02 PM, Yann Ylavic <ylavic.dev@gmail.com> wrote:
>>
>> On Wed, Feb 22, 2017 at 10:58 AM, Andrei Ivanov <andrei.ivanov@gmail.com>
>> wrote:
>> >
>> > So... do I have a chance to get it running on RHEL 7.3 which ships with
>> > 2.4.6?
>>
>> That may work in 2.4.6, I just didn't try ;)
>> "Require expr ... -in" exists (as far as I can tell), and so is
>> PeerExtList I think.
>> Did you try it?
>
>
> I didn't try on 2.4.6 because it fails even on 2.4.25:
> <Location />
>     Require expr "('IP Address:' . %{REMOTE_ADDR}) -in
> PeerExtList('2.5.29.17')"
> </Location>
>
> Cannot parse expression in require line: syntax error, unexpected ')'

My bad, please try without the parentheses:

    Require expr "'IP Address:' . %{REMOTE_ADDR} -in PeerExtList('2.5.29.17')"

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message