httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chunduru, Krishnachaithanya" <Krishnachaithanya.Chund...@broadridge.com>
Subject RE: [users@httpd] Apache upgrade on Aix
Date Sun, 12 Feb 2017 13:49:56 GMT
Hi Bharath,

Thanks a lot. Thanks.

Regards,
Krishna

-----Original Message-----
From: Bharath.C.Kolla@wellsfargo.com.INVALID [mailto:Bharath.C.Kolla@wellsfargo.com.INVALID]

Sent: Friday, February 10, 2017 11:50 PM
To: users@httpd.apache.org
Subject: RE: [users@httpd] Apache upgrade on Aix

Krishnachaitanya,

You can set compiler flags before time to set up the build environment. You might also need
coreutils depending on what your build server looks like. Below are some of the options that
come in handy:

export CC=/usr/vacpp/bin/xlc  --- or wherever you have the compiler installed export CXX=/usr/vacpp/bin/xlC

export PATH="/opt/freeware/bin:/usr/vacpp/bin:/usr/vac/bin:$PATH"
export CXXFLAGS="-xO2"
export CFLAGS="-xO2"

Notice that you are building an open source product on a AIX server and hence the need for
freeware & coreutils etc..

GL!!

Bharath Kolla


-----Original Message-----
From: Chunduru, Krishnachaithanya [mailto:Krishnachaithanya.Chunduru@broadridge.com]
Sent: Friday, February 10, 2017 5:54 AM
To: users@httpd.apache.org
Subject: RE: [users@httpd] Apache upgrade on Aix

Hi Bharath/William,

I have checked for the build directory under /var/build with config.nice file. 

There I could see what were the options used while compiling. 

Is there a way to proceed from here? Can you please help.

I'm a newbie to Apache !!

Regards,
Krishna

-----Original Message-----
From: Bharath.C.Kolla@wellsfargo.com.INVALID [mailto:Bharath.C.Kolla@wellsfargo.com.INVALID]
Sent: Wednesday, February 08, 2017 2:32 AM
To: users@httpd.apache.org
Subject: RE: [users@httpd] Apache upgrade on Aix

I installed the xlc compilers on AIX to compile Apache/openssl etc. On the other hand, I compiled
python 2.7.10 with gcc on AIX - 7.2 without any issues. So, if you are not sure of how the
old build was built, I would try and make the gcc work on AIX as IBM compilers are very expensive.
It’s the compiler and linker flags that usually differ compared to say, linux OS.

Bharath Kolla

-----Original Message-----
From: William A Rowe Jr [mailto:wrowe@rowe-clan.net]
Sent: Tuesday, February 07, 2017 1:42 PM
To: users@httpd.apache.org
Subject: Re: [users@httpd] Apache upgrade on Aix

There is a wealth of information in the build/ and build-1/ (APR) subdirectories about the
compiler and linker choices that were used to create a build, if they are preserved.


On Tue, Feb 7, 2017 at 8:38 AM, Chunduru, Krishnachaithanya <Krishnachaithanya.Chunduru@broadridge.com>
wrote:
> Hi Eric,
>
> Thanks for your reply.
>
> Actually the setup was done long back with a community version by a colleague who left
the organization.
>
> would it be possible to know how it was installed ?
>
> Regards,
> Krishna
>
> -----Original Message-----
> From: Eric Covener [mailto:covener@gmail.com]
> Sent: Tuesday, February 07, 2017 7:06 PM
> To: users@httpd.apache.org
> Subject: Re: [users@httpd] Apache upgrade on Aix
>
> On Tue, Feb 7, 2017 at 8:09 AM, Chunduru, Krishnachaithanya <Krishnachaithanya.Chunduru@broadridge.com>
wrote:
>> Can someone guide me on how to upgrade the Apache httpd from 2.4.10 
>> to
>> 2.4.16 or later version. I couldn’t find the proper documentation for 
>> doing this. Thanks.
>
>
> It depends where your old build came from. If you compiled it yourself, compile it again.
If you downloaded a package in lpp or rpm form, hunt for a new one.
>
> --
> Eric Covener
> covener@gmail.com
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>
> This message and any attachments are intended only for the use of the addressee and may
contain information that is privileged and confidential. If the reader of the message is not
the intended recipient or an authorized representative of the intended recipient, you are
hereby notified that any dissemination of this communication is strictly prohibited. If you
have received this communication in error, please notify us immediately by e-mail and delete
the message and any attachments from your system.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

B KKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKCB  [  X  ܚX KK[XZ[
 \ \  ][  X  ܚX P  \X K ܙ B  ܈Y][ۘ[  [X[  K[XZ[  \ \  Z[  \X
K ܙ B

This message and any attachments are intended only for the use of the addressee and may contain
information that is privileged and confidential. If the reader of the message is not the intended
recipient or an authorized representative of the intended recipient, you are hereby notified
that any dissemination of this communication is strictly prohibited. If you have received
this communication in error, please notify us immediately by e-mail and delete the message
and any attachments from your system.
B KKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKCB  [  X  ܚX KK[XZ[
 \ \  ][  X  ܚX P  \X K ܙ B  ܈Y][ۘ[  [X[  K[XZ[  \ \  Z[  \X
K ܙ B

This message and any attachments are intended only for the use of the addressee and may contain
information that is privileged and confidential. If the reader of the message is not the intended
recipient or an authorized representative of the intended recipient, you are hereby notified
that any dissemination of this communication is strictly prohibited. If you have received
this communication in error, please notify us immediately by e-mail and delete the message
and any attachments from your system.
Mime
View raw message