httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yann Ylavic <ylavic....@gmail.com>
Subject Re: [users@httpd] Httpd-2.4.23 not creating .so file
Date Thu, 12 Jan 2017 10:45:39 GMT
On Thu, Jan 12, 2017 at 11:42 AM, Yann Ylavic <ylavic.dev@gmail.com> wrote:
> On Thu, Jan 12, 2017 at 7:44 AM, Hemant Chaudhary
> <hemantdude.chaudhary@gmail.com> wrote:
>> Hi
>>
>> I am porting httpd-2.4.23 on nonstop tandem. But .so file is not created in
>> modules, hence I am unable to start apache.
>>
>> Only .a and .la of modules are present in module folder.
>>
>> Is it possible to start httpd-2.4.23 without .so file of modules ? If not
>> then how to create .so file.
>>
>> My configure command - ./configure   --with-included-apr
>> --with-pcre=/home/hemant/apache/httpd-2.4.23/srclib/pcre
>> --prefix=/home/hemant/apache
>
> You should be able to link the modules statically with
> --enable-mods-static="module1 module2..." (where "module1" is the name
> of some module without mod_ prefix, e.g. "rewrite" or "proxy"), or
> some predefined set with --enable-mods-static=few|most|all.
>
> Then the "LoadModule" in httpd.conf are not needed.

But if your system is usually able to link dynamically (ELF/.so is
handled), maybe you should force --enable-so and could then use
--enable-mods-shared="...".

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message