httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stéphane Laurencelle <stephane.laurence...@momentum-tech.ca>
Subject [users@httpd] RE : [users@httpd] problem compiling apache httpd server 2.4.25 with openssl 1.1.0c version on oel 6.8
Date Thu, 26 Jan 2017 20:27:06 GMT
that's what are read but is this true ?


Stéphane Laurencelle
Analyste Technologique

MOMENTUM TECHNOLOGIES INC.
Fière d’être parmi les 50 sociétés les mieux gérées du Canada<http://www.manitou-psa.com/index.php/qc/nous/nouvelles-2/86--momentum-technologies-parmi-les-50-societes-les-mieux-gerees-au-canada>!
825, boul. Lebourgneuf, bureau 412
Québec (Québec) G2J 0B9

Enterprise Téléphone :  418 681-6363
stephane.laurencelle@momentum-tech.ca<https://webmail.exchange.telus.com/owa/UrlBlockedError.aspx>
www.momentumtechnologies.ca<http://www.momentumtechnologies.ca/>

Vos experts en solutions Oracle et Java
Fiers d’être parmi les 50 sociétés les mieux gérées du Canada<http://www.momentumtechnologies.ca/fr/actualite_mieuxgerees.html>!
________________________________
De : Daniel [dferradal@gmail.com]
Envoyé : 26 janvier 2017 15:18
À : <users@httpd.apache.org>
Objet : Re: [users@httpd] problem compiling apache httpd server 2.4.25 with openssl 1.1.0c
version on oel 6.8

This has been said before in the mailing list very often. AFK apache 2.4.x is not compatible
with openssl 1.1.x.

2017-01-26 21:07 GMT+01:00 Stéphane Laurencelle <stephane.laurencelle@momentum-tech.ca<mailto:stephane.laurencelle@momentum-tech.ca>>:
Hello,

I'm trying to compile apache httpd 2.4.25 on oracle linux 6.8, i install openssl 1.1.0c version

here is the line i use to configure, this one did not return any error

./configure --prefix=/usr/local/src/httpd-2.4.25 --with-ssl=/usr/local/ssl --enable-ssl=shared
--with-mpm=worker --enable-so --enable-mods-shared=all --enable-proxy --with-apr=/usr/local/apr
--with-pcre=/usr/local/pcre

the next step i do is doing the command make to compile the httpd server and here is the error
i got at the end

/usr/local/apr/build-1/libtool --silent --mode=link gcc -std=gnu99  -g -O2 -pthread   -lssl
-lcrypto -lrt -lcrypt -lpthread  \
                 -o ab  ab.lo      /usr/local/apr/lib/libaprutil-1.la<http://libaprutil-1.la>
-lexpat /usr/local/apr/lib/libapr-1.la<http://libapr-1.la> -lrt -lcrypt -lpthread -lm
ab.o: In function `ssl_print_cert_info':
/usr/local/src/httpd-2.4.25/support/ab.c:640: undefined reference to `X509_get_version'
/usr/local/src/httpd-2.4.25/support/ab.c:642: undefined reference to `X509_getm_notBefore'
/usr/local/src/httpd-2.4.25/support/ab.c:646: undefined reference to `X509_getm_notAfter'
ab.o: In function `ssl_state_cb':
/usr/local/src/httpd-2.4.25/support/ab.c:562: undefined reference to `SSL_in_init'
/usr/local/src/httpd-2.4.25/support/ab.c:562: undefined reference to `SSL_is_server'
ab.o: In function `sk_X509_num':
/usr/local/include/openssl/x509.h:97: undefined reference to `OPENSSL_sk_num'
ab.o: In function `sk_X509_value':
/usr/local/include/openssl/x509.h:97: undefined reference to `OPENSSL_sk_value'
ab.o: In function `test':
/usr/local/src/httpd-2.4.25/support/ab.c:1877: undefined reference to `SSL_in_init'
ab.o: In function `main':
/usr/local/src/httpd-2.4.25/support/ab.c:2169: undefined reference to `TLS_client_method'
/usr/local/src/httpd-2.4.25/support/ab.c:2468: undefined reference to `CRYPTO_malloc_init'
/usr/local/src/httpd-2.4.25/support/ab.c:2470: undefined reference to `OPENSSL_init_ssl'
/usr/local/src/httpd-2.4.25/support/ab.c:2471: undefined reference to `OPENSSL_init_ssl'
/usr/local/src/httpd-2.4.25/support/ab.c:2480: undefined reference to `SSL_CTX_set_options'
/usr/local/src/httpd-2.4.25/support/ab.c:2395: undefined reference to `TLS_client_method'
collect2: ld returned 1 exit status
make[2]: *** [ab] Error 1
make[2]: Leaving directory `/usr/local/src/httpd-2.4.25/support'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/src/httpd-2.4.25/support'
make: *** [all-recursive] Error 1
[root@mandos httpd-2.4.25]

Hope someone hae a solution, i found some stuff about a bug on the 2.4.23 version and the
guys have to go back to the opsnssl 1.0.x version.

Best regards,

Stephane






--
Daniel Ferradal
IT Specialist

email         dferradal at gmail.com<http://gmail.com>
linkedin     es.linkedin.com/in/danielferradal<http://es.linkedin.com/in/danielferradal>

Mime
View raw message