httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel <dferra...@gmail.com>
Subject Re: [users@httpd] httpd-2.4.25 compile fail
Date Tue, 27 Dec 2016 09:34:35 GMT
Afaik httpd 2.4 is not yet compatible with openssl 1.1.x, the max version
you can use is 1.0.2x.

2016-12-27 1:24 GMT+01:00 Kent Frazier <frazier377@sbcglobal.net>:

> I'm trying (unsuccessfully) to build on a Mac Pro version 10.12.2
> (Sierra Darwin Kernel Version 16.3.0)
>
> libtool (GNU libtool) 2.4
>
> OpenSSL 1.1.0c  10 Nov 2016
>
> /usr/local/apr/build-1/libtool --silent --mode=link
> /Applications/Xcode.app/Contents/Developer/Toolchains/
> XcodeDefault.xctoolchain/usr/bin/cc
> -g -O2   -L/usr/local/lib -lssl -lcrypto -lpthread  \
>              -o ab  ab.lo       /usr/local/apr/lib/libaprutil-1.la
> -lexpat -liconv /usr/local/apr/lib/libapr-1.la -lpthread
> Undefined symbols for architecture x86_64:
>   "_CRYPTO_malloc_init", referenced from:
>       _main in ab.o
>   "_SSLv2_client_method", referenced from:
>       _main in ab.o
> ld: symbol(s) not found for architecture x86_64
>
> anybody know what's going on?
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>


-- 
*Daniel Ferradal*
IT Specialist

email         dferradal at gmail.com
linkedin     es.linkedin.com/in/danielferradal

Mime
View raw message