httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Dobák <erik.do...@gmail.com>
Subject Re: [users@httpd] ProxyPass not working?
Date Sat, 10 Dec 2016 21:20:44 GMT
what is ajp?

On 25 November 2016 at 20:11, Lou DeGenaro <lou.degenaro@gmail.com> wrote:

> Matching slashes worked!  Thanks.
>
> On Fri, Nov 25, 2016 at 11:00 AM, Daniel <dferradal@gmail.com> wrote:
>
>> Please match slashes when using proxypass and proxypassreverse otherwise
>> expect the unexpected.
>>
>> ProxyPass / http://localhost:8080/lophyda.com/
>>
>> 2016-11-25 16:10 GMT+01:00 Lou DeGenaro <lou.degenaro@gmail.com>:
>>
>>> I posted the entire configuration file.  Isn't that what /bin/cat does?
>>>
>>> Why do you suggest that DNS is not configured correctly?  I use GoDaddy
>>> to send my IP address to my router, and my router forwards the IP
>>> address:80 to my apache2 server.
>>>
>>> Which part of networking and Apache configuration do I not understand?
>>>
>>> Lou.
>>>
>>> On Fri, Nov 25, 2016 at 9:54 AM, Alexandru Duzsardi <
>>> alexandru.duzsardi@pitechnologies.ro> wrote:
>>>
>>>> I don’t understad where did you that URL from
>>>>
>>>> Do you see anywhere in the configuration file /lophyda.comlophyda.com/
>>>> ?
>>>>
>>>>
>>>>
>>>> ServerName lophyda.com – means that you should access the webserver
>>>> with that address
>>>>
>>>>
>>>>
>>>> If you don’t have DNS configured correctly then you should set it up
>>>> statically using the hosts file.
>>>>
>>>> Anyway , if you want to do this kind of work , you should first have a
>>>> basic understanding of networking and apache configuration.
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> *From:* Lou DeGenaro [mailto:lou.degenaro@gmail.com]
>>>> *Sent:* Friday, November 25, 2016 4:34 PM
>>>>
>>>> *To:* users@httpd.apache.org
>>>> *Subject:* Re: [users@httpd] ProxyPass not working?
>>>>
>>>>
>>>> HTTP Status 404 - /lophyda.comlophyda.com/
>>>>
>>>> root@HAL9000:/etc/apache2/sites-enabled# cat lophyda.com.conf
>>>> <VirtualHost *:80>
>>>>     ServerName lophyda.com
>>>>
>>>>     ProxyPass / http://localhost:8080/lophyda.com
>>>>     ProxyPassReverse / http://localhost:8080/lophyda.com
>>>>
>>>>     LogLevel warn
>>>> </VirtualHost>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> On Fri, Nov 25, 2016 at 8:44 AM, Alexandru Duzsardi <
>>>> alexandru.duzsardi@pitechnologies.ro> wrote:
>>>>
>>>> ProxyPreserveHost is kind of useless in your case
>>>>
>>>> Take a look at  https://httpd.apache.org/docs/
>>>> current/mod/mod_proxy.html#proxypass
>>>>
>>>>
>>>>
>>>> This should work
>>>>
>>>>
>>>>
>>>> <VirtualHost *:80>
>>>>     ServerName lophyda.com
>>>>
>>>>
>>>>     ProxyPass / http://localhost:8080/lophyda.com
>>>>     ProxyPassReverse / http://localhost:8080/lophyda.com
>>>>
>>>>     LogLevel warn
>>>> </VirtualHost>
>>>>
>>>>
>>>>
>>>> Or
>>>>
>>>>
>>>>
>>>> <VirtualHost *:80>
>>>>     ServerName lophyda.com
>>>>
>>>>
>>>>
>>>>     <Location />
>>>>     ProxyPass http://localhost:8080/lophyda.com
>>>>     </Location>
>>>>
>>>>
>>>>     LogLevel warn
>>>> </VirtualHost>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> *From:* Lou DeGenaro [mailto:lou.degenaro@gmail.com]
>>>> *Sent:* Friday, November 25, 2016 3:24 PM
>>>> *To:* users@httpd.apache.org
>>>> *Subject:* Re: [users@httpd] ProxyPass not working?
>>>>
>>>>
>>>>
>>>> Still trying. On ubuntu 16.04.
>>>>
>>>> I have tomcat installed.  Visiting localhost:8080 yields normal tomcat
>>>> welcome page.  Visiting localhost:8080/lophyda.com yields my website
>>>> welcome page, as expected.
>>>>
>>>> I have apache2 installed.  Visiting localhost:80 yields normal apache
>>>> welcome page.  Visiting lophyda.com yields the same?
>>>>
>>>> I expected that since I used "lophyda.com" to visit that I'd get
>>>> forwarded to tomcat and see my lophyda.com website?
>>>>
>>>> Here is my conf file:
>>>>
>>>> root@HAL9000:/etc/apache2/sites-available# cat lophyda.com.conf
>>>> <VirtualHost *:80>
>>>>     ProxyRequests off
>>>>     ProxyPreserveHost on
>>>>     ServerName lophyda.com
>>>>
>>>>     ServerAdmin lou@localhost
>>>>     ProxyPass http://lophyda.com http://localhost:8080/lophyda.com
>>>>     ProxyPassReverse http://lophyda.com http://localhost:8080/lophyda.
>>>> com
>>>>
>>>>     LogLevel warn
>>>> </VirtualHost>
>>>>
>>>> What am I doing wrong?
>>>>
>>>> Thanks.
>>>>
>>>> Lou.
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> On Thu, Nov 10, 2016 at 6:21 PM, Lou DeGenaro <lou.degenaro@gmail.com>
>>>> wrote:
>>>>
>>>> Why?  I see: port 80 namevhost degenaro.com
>>>> (/etc/apache2/sites-enabled/degenaro.com.conf:1)
>>>>
>>>>
>>>>
>>>> On Thu, Nov 10, 2016 at 7:05 AM, Daniel <dferradal@gmail.com> wrote:
>>>>
>>>> when you visit localhost/degenaro.com it will be delivered to
>>>> (/etc/apache2/sites-enabled/000-default.conf:1)
>>>>
>>>> if you want to be delivered to (/etc/apache2/sites-enabled/degenaro.com.conf:1)
>>>> you must request
>>>>
>>>> using the appropiate name.
>>>>
>>>>
>>>>
>>>> 2016-11-10 11:38 GMT+01:00 Lou DeGenaro <lou.degenaro@gmail.com>:
>>>>
>>>> root@HAL9000:/etc/apache2/sites-enabled# apachectl -S
>>>> VirtualHost configuration:
>>>> *:80                   is a NameVirtualHost
>>>>          default server 192.168.1.80 (/etc/apache2/sites-enabled/00
>>>> 0-default.conf:1)
>>>>          port 80 namevhost 192.168.1.80 (/etc/apache2/sites-enabled/00
>>>> 0-default.conf:1)
>>>>          port 80 namevhost degenaro.com (/etc/apache2/sites-enabled/de
>>>> genaro.com.conf:1)
>>>> ServerRoot: "/etc/apache2"
>>>> Main DocumentRoot: "/var/www/html"
>>>> Main ErrorLog: "/var/log/apache2/error.log"
>>>> Mutex proxy: using_defaults
>>>> Mutex default: dir="/var/lock/apache2" mechanism=fcntl
>>>> Mutex mpm-accept: using_defaults
>>>> Mutex watchdog-callback: using_defaults
>>>> PidFile: "/var/run/apache2/apache2.pid"
>>>> Define: DUMP_VHOSTS
>>>> Define: DUMP_RUN_CFG
>>>> User: name="www-data" id=33
>>>> Group: name="www-data" id=33
>>>>
>>>> Perhaps my expectations are wrong?  When I visit localhost/degenaro.com
>>>> should I not be taken to localhost:8080/degenaro.com?
>>>>
>>>>
>>>>
>>>> On Wed, Nov 9, 2016 at 7:05 PM, Eric Covener <covener@gmail.com> wrote:
>>>>
>>>>
>>>>     ServerName degenaro.com
>>>>
>>>> I've restated the apache server, and visit
>>>> http://localhost/degenaro.com/ and see this in my browser:
>>>>
>>>> ​
>>>> Request likely not going to the virtual host you configured.  See
>>>> apachectl -S for a summary.​
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> --
>>>>
>>>> *Daniel Ferradal*
>>>>
>>>> IT Specialist
>>>>
>>>>
>>>>
>>>> email         dferradal at gmail.com
>>>>
>>>> linkedin     es.linkedin.com/in/danielferradal
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>> --
>> *Daniel Ferradal*
>> IT Specialist
>>
>> email         dferradal at gmail.com
>> linkedin     es.linkedin.com/in/danielferradal
>>
>
>

Mime
View raw message