httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Otis Dewitt - NOAA Affiliate <otis.dew...@noaa.gov>
Subject Re: [users@httpd] Web sockets & proxypass - No protocol handler was valid for the URL
Date Tue, 27 Dec 2016 14:22:18 GMT
Check this link out.

http://stackoverflow.com/questions/17889676/apache-2-4-6-reverseproxy-mod-proxy-wstunnel-for-secure-websocket-wss-fails

Thanks,
Otis

On Tue, Dec 27, 2016 at 8:55 AM, Daniel <dferradal@gmail.com> wrote:

> Silly question perhaps, are you also loading mod_ssl?
>
> 2016-12-27 14:39 GMT+01:00 Adam Teale <adam@believe.tv>:
>
>> Hi!
>>
>> I've been trying to setup a reverse proxy to a localhost websocket url.
>>
>> ProxyPass /chat/stream/ wss://localhost:8000/chat/stream/
>> ProxyPassReverse /chat/stream/ wss://localhost:8000/chat/stream/
>>
>> I get an error in the apache error_log that reads:
>>
>> No protocol handler was valid for the URL /chat/stream/. If you are using
>> a DSO version of mod_proxy, make sure the proxy submodules are included in
>> the configuration using LoadModule.
>>
>> I have read a lot of pages via google of people using this method so I
>> wonder if there is some issue in our setup/install of Apache that ships
>> with Mac OS X 10.11 & Server.app 5.2?
>>
>> I have all the standard modules loaded in httpd_server_app.conf
>>
>> LoadModule proxy_module libexec/apache2/mod_proxy.so
>> LoadModule proxy_http_module libexec/apache2/mod_proxy_http.so
>> LoadModule proxy_wstunnel_module libexec/apache2/mod_proxy_wstunnel.so
>>
>> When I access the application running on localhost:8000 directly on the
>> server everything works fine
>>
>> Any ideas what could be going on?
>>
>> Thanks!
>>
>> Adam
>> Apache 2.4.18, Mac OS X 10.11, Server.app 5.2
>>
>
>
>
> --
> *Daniel Ferradal*
> IT Specialist
>
> email         dferradal at gmail.com
> linkedin     es.linkedin.com/in/danielferradal
>

Mime
View raw message