httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: [users@httpd] HTTPD 2.4.25 crash in mod_proxy (ajp)
Date Fri, 23 Dec 2016 12:18:36 GMT
BCC: Steffen

I did quick tests to verify whether shutdown issues are related to
mod_proxy.  They are not related.

2016-12-23 15:01 GMT+03:00 Konstantin Kolinko <knst.kolinko@gmail.com>:
>
> 2. Oddities at shutdown that I also mentioned are still there.
>
> I mean the following:
> - On Windows 7 (running as service, complex configuration):
> "AH00431: Parent: Forcing termination of child process" log message
>
> I do not see such message in old logs from 2.4.23.
>
> Maybe the process is still broken, although it did not crash?

Quick test:

1) Start server service, Stop server service   (No HTTPS requests served)

No issue.

[Fri Dec 23 15:06:22.542629 2016] [mpm_winnt:notice] [pid 2636:tid
364] AH00422: Parent: Received shutdown signal -- Shutting down the
server.
[Fri Dec 23 15:06:24.570633 2016] [mpm_winnt:notice] [pid 3996:tid
256] AH00364: Child: All worker threads have exited.
[Fri Dec 23 15:06:24.648633 2016] [mpm_winnt:notice] [pid 2636:tid
364] AH00430: Parent: Child process 3996 exited successfully.

2) Start server service, Request a static page (root page of the
site), Stop server service.

The child process does not stop, is terminated forcedly.

[Fri Dec 23 15:07:02.353899 2016] [mpm_winnt:notice] [pid 3084:tid
364] AH00422: Parent: Received shutdown signal -- Shutting down the
server.
[Fri Dec 23 15:07:32.368352 2016] [mpm_winnt:notice] [pid 3084:tid
364] AH00431: Parent: Forcing termination of child process 5564

So this issue is real, but it is not related to mod_proxy.


> - On Windows 10 (running as console, simple configuration example - GitHub):
>
> Before I hit Ctrl+C the error.log file is as follows:
> (I added additional line breaks to separate lines that are wrapped in e-mail.)
> ...
> After I hit Ctrl+C in HTTPD console window, it becomes:
> (I added additional line breaks to separate lines that are wrapped in e-mail.)
> ...
>
> The "Apache server interrupted..." line appears in the middle of the
> file, overwriting some of existing text.
>

Quick test:

1) Start server service, Stop server service   (No HTTPS requests served)

This issue is observed.
("Apache server interrupted..." line appears in the middle of the file).

So this oddity is real, but it is not related to mod_proxy, not
related to processing of HTTP requests.

Maybe this is not a real issue, just an oddity.


Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message