httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From D'Arcy Cain <da...@vex.net>
Subject [users@httpd] Trouble with Action directive
Date Sat, 10 Dec 2016 19:27:57 GMT
I am trying to get rid of the PHP module for various reasons.  I tried
adding the following directives in my .htaccess as a test.  The idea is
to eventually move that into httpd.conf.

AddHandler phpweb .php
Action phpweb /cgi-bin/phpweb

The binary phpweb is a tine program that simply execs the real PHP web
handler.  I do that so that it runs the current version.  It needs to be
in my directory because of suExec.  I have this in httpd.conf.

ScriptAlias /cgi-bin/ MYWEBDIR/cgi-bin/

MYWEBDIR is replaced by my specific web directory.  Each user has a
VirtualHost section where that string is replaced with their web directory.

Now I go to http://testing.fake/test.php.  The fake domain is used by me
for testing.  If someone wants to test this I could put it into a real
domain.  The result is...

    The requested URL /cgi-bin/phpweb/test.php was not found on this server.

The actual action should be to run /cgi-bin/phpweb with
MYWEBDIR/test.php as the argument or as the standard input.  What am I
doing wrong here?

-- 
D'Arcy J.M. Cain
System Administrator, Vex.Net
http://www.Vex.Net/ IM:darcy@Vex.Net
VoIP: sip:darcy@Vex.Net

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message