httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel <dferra...@gmail.com>
Subject Re: [users@httpd] ProxyPass not working?
Date Thu, 10 Nov 2016 12:05:58 GMT
when you visit localhost/degenaro.com it will be delivered to
(/etc/apache2/sites-enabled/000-default.conf:1)

if you want to be delivered to (/etc/apache2/sites-enabled/degenaro.com.conf:1)
you must request
using the appropiate name.

2016-11-10 11:38 GMT+01:00 Lou DeGenaro <lou.degenaro@gmail.com>:

> root@HAL9000:/etc/apache2/sites-enabled# apachectl -S
> VirtualHost configuration:
> *:80                   is a NameVirtualHost
>          default server 192.168.1.80 (/etc/apache2/sites-enabled/
> 000-default.conf:1)
>          port 80 namevhost 192.168.1.80 (/etc/apache2/sites-enabled/
> 000-default.conf:1)
>          port 80 namevhost degenaro.com (/etc/apache2/sites-enabled/
> degenaro.com.conf:1)
> ServerRoot: "/etc/apache2"
> Main DocumentRoot: "/var/www/html"
> Main ErrorLog: "/var/log/apache2/error.log"
> Mutex proxy: using_defaults
> Mutex default: dir="/var/lock/apache2" mechanism=fcntl
> Mutex mpm-accept: using_defaults
> Mutex watchdog-callback: using_defaults
> PidFile: "/var/run/apache2/apache2.pid"
> Define: DUMP_VHOSTS
> Define: DUMP_RUN_CFG
> User: name="www-data" id=33
> Group: name="www-data" id=33
>
> Perhaps my expectations are wrong?  When I visit localhost/degenaro.com
> should I not be taken to localhost:8080/degenaro.com?
>
> On Wed, Nov 9, 2016 at 7:05 PM, Eric Covener <covener@gmail.com> wrote:
>
>>
>>>     ServerName degenaro.com
>>>
>>> I've restated the apache server, and visit
>>> http://localhost/degenaro.com/ and see this in my browser:
>>>
>> ​
>> Request likely not going to the virtual host you configured.  See
>> apachectl -S for a summary.​
>>
>>
>>
>
>


-- 
*Daniel Ferradal*
IT Specialist

email         dferradal at gmail.com
linkedin     es.linkedin.com/in/danielferradal

Mime
View raw message