httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yehuda Katz <yeh...@ymkatz.net>
Subject Re: [users@httpd] Http sessions seems to get mixed with Apache SSL offload/reverse proxy for Exchange 2013 server
Date Tue, 29 Nov 2016 22:58:25 GMT
Your best bet might be mod_dumpio and/or sniffing the traffic on each side
of Apache.
Posting your Virtual Host and Proxy config might help too.

Also, it looks like other people appear to have this working (unless they
don't use Mac). For example, I found this config:
https://github.com/phr0gz/Apache-reverse-proxy-for-Exchange-2010-2013-2016

- Y

On Tue, Nov 29, 2016 at 5:41 PM, Lars Bonnesen <lars.bonnesen@gmail.com>
wrote:

> It seems that when a Mac client tries to access an Exchange 2013 server
> having an Apache reverse proxy (non-caching) in between a number a strange
> issues are seen:
>
> 1) Inbox come and go from time to time.
>
> ... and what is even worse
>
> 2) Mail send from one person seems to arrive from another.
>
> 3) Mails destined for other users gets mixed into some users mailbox (that
> is... they are in the Mac inbox but not on OWA)
>
> We only see this on Mac clients. Never on App from Google Play or iStore.
> Never on Outlook clients connection within the local LAN (can't connect
> with outlook from external LAN as Apache does not like the http RPC that MS
> uses).
>
> I was originally posting the case here:
>
> https://social.technet.microsoft.com/Forums/office/
> en-US/90090d72-3c49-4dbb-a1a9-72c20dcb1336/macclients-gets-
> mails-mixed-from-other-users?forum=exchangesvrclients#
> af954ae8-47d6-41e1-a320-03badf17374a
>
> and one of the suggestions was to take Apache out of the chain.
>
> I would like to keep it there though - If I can manage to solve the three
> issues mentioned above.
>
> Has anyone seen something like this - and if so, did you manage to solve
> it?
>
> Regards, Lars.
>
>
>

Mime
View raw message