httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gerhard Mourani <gmour...@gmail.com>
Subject Re: [users@httpd] mod_authnz-ldap & %20
Date Wed, 09 Nov 2016 15:55:12 GMT
This is what I've used as ldapsearch command for my test:

ldapsearch -x -h 192.168.2.40 -D "administrator@domain.com" -W -b "OU=Privilege Groups,OU=Users
Specials,DC=domain,DC=com" -s sub "(cn=*)" cn mail sn

And get the following result which show to me that it is not working.

Enter LDAP Password: 
# extended LDIF
#
# LDAPv3
# base <OU=Privilege Groups,OU=Users Specials,DC=domain,DC=com> with scope subtree
# filter: (cn=*)
# requesting: cn mail sn 
#

# search result
search: 2
result: 32 No such object
matchedDN: DC=domain,DC=com
text: 0000208D: NameErr: DSID-03100238, problem 2001 (NO_OBJECT), data 0, best 
 match of:
	'DC=domain,DC=com'

Gerhard,

> On Nov 8, 2016, at 12:06 PM, Eric Covener <covener@gmail.com> wrote:
> 
> On Tue, Nov 8, 2016 at 11:37 AM, Gerhard Mourani <gmourani@gmail.com> wrote:
>> I've a problem to make mod_authnz-ldap work with space in AuthLDAPUrl
>> parameter. Here my config:
> 
> 
> I would not have thought a space would require escaping. Do you get an
> error from the LDAP server?  Can you try some command line ldapsearch
> searches and see if it implicitly encodes anything for you?  I believe
> LDAP escaping would be \20 or \\20 depending on how many layers
> interpret the string.
> 
> 
> 
> -- 
> Eric Covener
> covener@gmail.com
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 


Mime
View raw message